Opened 10 years ago

Closed 10 years ago

#3165 closed enhancement (wontfix)

The 'Forever' block doesn't need and extender block attached

Reported by: garycmartin Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

The ‘Forever’ repeat block does not need a continuation extender block automatically attached. Or really even have a block connector on bottom edge as it should not allow bricks to attach that will never be executed (I could find no break type flow control brick) – this last step seems to be voided by the need for the collapsed stack bricks to be placed at the top and bottom of a block to fold away.

Attachments (1)

Captura pantalla de _sugar-activity__7.png (64.8 KB) - added by walter 10 years ago.

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by walter

comment:1 Changed 10 years ago by walter

  • Resolution set to wontfix
  • Status changed from new to closed

The Stop Action block will break a Forever loop as per the attached image.

Note: See TracTickets for help on using tickets.