Opened 10 years ago

Closed 10 years ago

#3120 closed defect (fixed)

portfolio divide by zero

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Portfolio Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

w= int (self._width/n) line 527

portfolio locked up though it might be 1.75 os6 driver issues, there was an error in the log, divide by zero

Change History (6)

comment:1 Changed 10 years ago by tonyforster

locked up again, blank grey canvas, no toolbar, but this time no errors logged

comment:2 Changed 10 years ago by tonyforster

blank screen logged as laptop 11273

comment:3 Changed 10 years ago by walter

Hmm. I pushed a patch for the divide-by-zero error, which would have been triggered by going to the Thumbnail view when there are no starred entries in the Journal. Can you please try pulling this patch and testing again?

http://git.sugarlabs.org/portfolio/portfolio/commit/43aac18ef602227483449a4bda821166524233a6

comment:4 Changed 10 years ago by tonyforster

No logged errors, with or without starred entries. The divide by zero probably had no consequences for the user.

laptop 11273 still happens but I expect its an unrelated video driver problem

comment:5 Changed 10 years ago by erikos

Thanks Tony for the report it might be the same x-driver issue we have seen in Browse. But good Walter fixed the diivision/0 issue anyhow.

comment:6 Changed 10 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.