Opened 12 years ago

Closed 12 years ago

#29 closed defect (wontfix)

NM 0.7 support for sugar 0.82

Reported by: erikos Owned by: marcopg
Priority: major Milestone:
Component: Sugar Version: 0.82.x
Severity: Blocker Keywords: r?
Cc: morgan.collett@… Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

These patches are meant to give networking to distributions that ship 0.82 and NetworkManager 0.7. I make this critical sine this should make it into F10 and we have freeze already.

Attachments (2)

nm07-support.patch (170.7 KB) - added by erikos 12 years ago.
suprt of wireless connections with NM 0.7 (this drops NM 0.6 support)
sugar-dispatcher.patch (22.7 KB) - added by erikos 12 years ago.
the sugar dispatcher is used by the NM connections

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by erikos

suprt of wireless connections with NM 0.7 (this drops NM 0.6 support)

Changed 12 years ago by erikos

the sugar dispatcher is used by the NM connections

comment:1 Changed 12 years ago by erikos

  • Keywords r? added

so we need to patch sugar and sugar-base.

comment:2 Changed 12 years ago by morgs

  • Cc morgan.collett@… added

comment:3 Changed 12 years ago by morgs

I applied these patches in ubuntu, but I get the following problem:

1228226765.808315 DEBUG root: Error getting the active access point: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "(unset)" member "Get" error name "(unset)" destination ":1.9")
1228226765.853322 DEBUG root: Error getting the access point properties: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "(unset)" member "Get" error name "(unset)" destination ":1.9")

etc.

My APs show in Neighborhood view, but don't have any visible name in the menu.

comment:4 Changed 12 years ago by erikos

Interesting, I have seen similar errors in joyride #69. So at least WPA is broken there. In F10 I do not have this issue.

comment:5 Changed 12 years ago by mungewell

Just to 'ping this up' I am also seeing the similar behaviour of missing names on APs with jhbuild (20080107 or so) on Intrepid.

Mungewell.

comment:6 Changed 12 years ago by tomeu

  • Version set to 0.82.x

comment:7 Changed 12 years ago by marcopg

  • Bug Status set to Unconfimed
  • Distribution/OS set to Unspecified
  • Resolution set to wontfix
  • Severity set to Blocker
  • Status changed from new to closed

0.84 is coming up and we should be focusing on it. I'd let distributions deal with improving these patches.

Note: See TracTickets for help on using tickets.