Opened 10 years ago

Closed 9 years ago

#2731 closed defect (fixed)

Measure activity seems to write empty "Measure Log" files

Reported by: greenfeld Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Measure Version: 0.92.x
Severity: Major Keywords: 11.3.0
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

The Measure activity can Record plot points, which I believe is how it can add one or more "Measure Log" objects to Sugar's journal. {How one renames these from within the activity I don't know.} These "Measure Log" objects appear to be text files openable by Write or Etoys. They get saved to USB sticks as CSV (comma separated value) data files.

But when you open one of these log files up in Write or manually from the USB stick, there is no data inside! The USB file stored is zero bytes in length.

Perhaps I am doing something wrong, or this is not user friendly enough for me to figure out?

Change History (4)

comment:1 Changed 10 years ago by godiard

  • Keywords 11.3.0 added; 11.2.0 removed

comment:2 Changed 10 years ago by walter

I managed to overlook this ticket. Will investigate and perhaps it is time to update the Measure documentation.

comment:3 Changed 9 years ago by walter

How one renames these from within the activity I don't know.

You can rename the log file created in the Journal

But when you open one of these log files up in Write or manually from the USB stick, there is no data inside! The USB file stored is zero bytes in length.

Should be fixed in Measure 36

Note that as of Measure 36, logging is a bit different than before:

All logging data for a particular instance of Measure is stored as CSV in the Measure activity metadata (more accurately, the file saved in the write_file method). It is also exported onto a separate document, Measure.log, which is created in the Journal. (The reason for saving it into two places is due to #2127)

The CSV header now includes a date/time stamp, the mode of capture, the sample number (and channel, in the case of stereo capture).

Note that every time you log data with an instance of Measure, it creates a *new* Measure.log file, which contains *all* of the logs associated with that instance of Measure.

There is no longer a facility for recording multiple screen captures. These can be recorded individually using the save image to Journal button on the toolbar.

Please test and report back.

comment:4 Changed 9 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

Closing as fixed. Please reopen if the problem persists.

Note: See TracTickets for help on using tickets.