Opened 10 years ago

Closed 10 years ago

#2127 closed defect (fixed)

Write changes file types

Reported by: walter Owned by: godiard
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Write Version: Unspecified
Severity: Unspecified Keywords: r?
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Write seems to change file types by default from the type opened. For example:

  1. Open a .csv file in Write
  2. Exit Write (without making any changes)
  3. Observe that the file is no longer .csv

(I encounter this problem in Measure: I capture data into a .csv file. But if I open that file in Write, it is no longer .csv.)

Attachments (2)

Change History (7)

comment:1 Changed 10 years ago by erikos

  • Owner set to godiard
  • Status changed from new to assigned

Thanks Gonzalo for the patch. So, this is a tricky issue actually. Do we treat Write as a viewer for files like *.patch, *.c, *.html? Or in which cases do we have to change the format because after someone has edited in Write it becomes another format? In my opinion it should stay the original format unless after editing it can not be anymore.

Example: With your code a c-file with the mimetype: text/x-csrc is changed to 'application/vnd.oasis.opendocument.text'.

comment:2 Changed 10 years ago by walter

Now that we have a Edit activity, which is plain text, we can do an end-run around this problem. Maybe make Edit handle all the plain-text situations and let people use the clipboard if they really want plain text in Write???

comment:3 Changed 10 years ago by godiard

  • Keywords r? added

I added a new patch to try to solve the same problem.

comment:4 Changed 10 years ago by RafaelOrtiz

comment:5 Changed 10 years ago by godiard

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.