Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#267 closed enhancement (duplicate)

Explicitly inherited method to (re)construct activity GUI after loading(possible) journal entity in sugar-toolkit

Reported by: alsroot Owned by: marcopg
Priority: Low Milestone:
Component: Sugar Version: 0.83.x
Severity: Minor Keywords: tomeu
Cc: Distribution/OS: Unspecified
Bug Status: New

Description

now, read_file() calling placed in map event handler

if I want to construct activity's gui according to loaded jobject
I have to use connect_after("map") and rely on the fact that read_file() will be called before (of course I could call this construction from overloaded read_file but in that case I should count situation w/o loading jobject)

better way is declaring method in Activity class to handle this interval: after init(), read_file() invoking(possible) and before showing gui

Change History (9)

comment:1 follow-up: Changed 12 years ago by tomeu

  • Keywords tomeu added

Why don't you update your UI in read_file()?

comment:2 in reply to: ↑ 1 ; follow-up: Changed 12 years ago by alsroot

Replying to tomeu:

Why don't you update your UI in read_file()?

sometime there is differences between "just construct" and "reconstruct existed"

comment:3 in reply to: ↑ 2 ; follow-up: Changed 12 years ago by alsroot

Replying to alsroot:

Replying to tomeu:

Why don't you update your UI in read_file()?

sometime there is differences between "just construct" and "reconstruct existed"

moreover in case of having new method there is only one place to collect logic (otherwise in init() and in read_file())

comment:4 in reply to: ↑ 3 Changed 12 years ago by tomeu

Replying to alsroot:

Replying to alsroot:

Replying to tomeu:

Why don't you update your UI in read_file()?

sometime there is differences between "just construct" and "reconstruct existed"

moreover in case of having new method there is only one place to collect logic (otherwise in init() and in read_file())

I'm a bit concerned about making the Activity class more complicated. It's already quite messy and that is confusing activity authors.

Cannot we say that activity authors that find themselves in this situation can construct their UI by calling a single function from init and read_file?

comment:5 Changed 12 years ago by tomeu

  • Milestone changed from Unspecified by Release Team to 0.86

As any solution to this issue would involve API modifications, I'm moving it to 0.86.

comment:6 Changed 12 years ago by marcopg

  • Bug Status changed from Unconfimed to New
  • Priority changed from Unspecified by Maintainer to Normal
  • Version changed from Unspecified to 0.83.x

comment:7 Changed 12 years ago by alsroot

  • Priority changed from Normal to Low

comment:8 Changed 12 years ago by alsroot

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #428

comment:9 Changed 8 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.