Opened 10 years ago

Closed 10 years ago

#2564 closed defect (fixed)

not associated with backup files

Reported by: sridhar Owned by: sascha_silbe
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Restore Version: Git as of bugdate
Severity: Blocker Keywords:
Cc: sridhar Distribution/OS:
Bug Status: New

Description

Description

Tested on XO build au360 (based on 10.1.3).

Steps to reproduce:

  1. make a backup of the datastore to a USB drive using the Backup activity
  2. hover over the resultant .xmj file in the journal

What should happen:
There should be a context menu option to open in the Restore activity. Or, if you just click the file's icon, it should open in Restore.

What actually happens:

  • the context menu shows "No activity to start entry"
  • clicking on the icon does nothing

At a guess, it looks like the MIME type for .xmj isn't being registered correctly.

This bug makes restoring impossible, so I would consider it to be a Blocker. The last time I saw it working was on a 10.1.2-based build. I don't know if there's a relationship there.

More information in OLPC Australia's tracker: https://dev.laptop.org.au/issues/328

Change History (5)

comment:1 Changed 10 years ago by sridhar

Australian schools really need the ability to backup and restore, so fixing this bug would be greatly appreciated.

comment:2 Changed 10 years ago by sridhar

  • Cc sridhar added

comment:3 follow-up: Changed 10 years ago by sascha_silbe

  • Bug Status changed from Unconfirmed to New
  • Distribution/OS OLPC deleted
  • Status changed from new to accepted
  • Version changed from 0.84.x to Git as of bugdate

Restore is writing directly to the external storage medium (because there's no Sugar API for that, at least for Sugar 0.84+). The MIME type is "detected" by the Journal, not set by Backup. In order for the MIME type to be correctly detected, you need to either:

  1. install Restore from a .xo bundle (and possibly restart Sugar - haven't checked)
  2. have the fix for #2262 applied and installed Restore in the system (using setup.py)

These need to happen before viewing the external medium that contains the backup.

I'll check whether we can include the mimetypes.xml from Restore in Backup without adverse effects. That would work around the issue.

comment:4 in reply to: ↑ 3 Changed 10 years ago by sascha_silbe

Replying to sascha_silbe:

Restore is writing directly to the external storage medium [...]

This should have read "Backup", of course. The other references to Restore are correct.

comment:5 Changed 10 years ago by sascha_silbe

  • Resolution set to fixed
  • Status changed from accepted to closed

Version 4 includes the mimetypes.xml from Restore. Now it suffices if Backup is installed before listing the storage device. All other restrictions still apply, though.

Note: See TracTickets for help on using tickets.