Opened 10 years ago

Closed 7 years ago

#2304 closed defect (obsolete)

Salut uses different nick name than Sugar

Reported by: sascha_silbe Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Minor Keywords:
Cc: Distribution/OS:
Bug Status: Unconfirmed

Description

Observed the following in telepathy-salut.log:

(telepathy-salut:14931): tp-glib/params-DEBUG: tp_cm_param_setter_offset: nickname = "Sascha Silbe"
(telepathy-salut:14931): tp-glib/params-DEBUG: tp_cm_param_setter_offset: first-name = ""
(telepathy-salut:14931): tp-glib/params-DEBUG: tp_cm_param_setter_offset: last-name = ""
(telepathy-salut:14931): tp-glib/params-DEBUG: tp_cm_param_setter_offset: jid = "d0693262a0d0ae006cc9fedca6d8176571a0a3a9@flatty.sascha.silbe.org"
(telepathy-salut:14931): tp-glib/params-DEBUG: tp_cm_param_setter_offset: published-name = "Sascha Silbe"

My configure nick name in Sugar is different from the above. On many machines (e.g. running OLPC builds) the GECOS name will be something generic.

Without further testing (due to #2217) I assume that this name will appear on other local clients (e.g. running GNOME), so we should fix this.

Attachments (1)

telepathy-salut.log (5.6 KB) - added by sascha_silbe 10 years ago.
telepathy-salut.log showing published-name and nickname set to the GECOS full name

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by sascha_silbe

telepathy-salut.log showing published-name and nickname set to the GECOS full name

comment:1 follow-up: Changed 10 years ago by tomeu

We are configuring the connections with the name in /desktop/sugar/user/nick

http://git.sugarlabs.org/projects/sugar/repos/nops/blobs/master/src/jarabe/model/neighborhood.py#line640

What I think it's happening is that Sugar is using the GECOS name as the initial nick name.

comment:2 in reply to: ↑ 1 Changed 10 years ago by sascha_silbe

  • Summary changed from Salut: GECOS full name instead of Sugar nick name used to Salut uses different nick name than Sugar

Replying to tomeu:

We are configuring the connections with the name in /desktop/sugar/user/nick

http://git.sugarlabs.org/projects/sugar/repos/nops/blobs/master/src/jarabe/model/neighborhood.py#line640

I have Telepathy installed both in the distro and in sugar-jhbuild, regular dbus in the distro and GConf-dbus in sugar-jhbuild. It might be that this leads to different gconf databases being used by Sugar and by Telepathy. The non-dbus one contains "Sascha Silbe" as nick name.
So with some luck this might resolve itself once we kick GConf-dbus from sugar-jhbuild and have up-to-date Telepathy packages in the distros.

comment:3 Changed 7 years ago by dnarvaez

  • Resolution set to obsolete
  • Status changed from new to closed

Very old, not reproducable.

Note: See TracTickets for help on using tickets.