Opened 10 years ago

Closed 7 years ago

#2298 closed defect (notsugar)

failure to retrieve buddy properties due to timeouts

Reported by: tomeu Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: rgs, seeta_dev Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

jabber.sugarlabs.org is at times quite slow at returning queries, probably because of some internal throttle mechanism.

Change History (3)

comment:1 in reply to: ↑ description Changed 10 years ago by tomeu

Replying to tomeu:

jabber.sugarlabs.org is at times quite slow at returning queries, probably because of some internal throttle mechanism.

Some investigation showed that the problem is that these queries are resolved very inefficiently by ejabberd when there are a few hundreds of _registered_ users.

comment:2 Changed 10 years ago by rgs

  • Cc rgs seeta_dev added

I think I am hitting these timeout errors.

Do the following messages (extracted from shell.log) look familiar (and associated with this problem) to you?

Error 1:

RuntimeError: Error when calling BuddyInfo.GetProperties: org.freedesktop.Telepathy.Error.NetworkError: Failed to query the PEP node: the addressed JID or item requested cannot be found

Error 2:

RuntimeError: Error when calling BuddyInfo.GetActivities: org.freedesktop.Telepathy.Error.NetworkError: Error in pubsub reply: server error

I'll try to look closely into ejabberd to see whats actually going on.

comment:3 Changed 7 years ago by dnarvaez

  • Resolution set to notsugar
  • Status changed from new to closed

I'd blame this on the server, it should answer within a reasonable time.

Note: See TracTickets for help on using tickets.