Opened 9 years ago

Closed 6 years ago

#2250 closed defect (obsolete)

webactivity as picture viewer refused to stop on os851

Reported by: carrott Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: 0.84.x
Severity: Minor Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

Browse-108 on os851 on XO-1

Opened picture from the journal, WebActivity opened it as normal, but refused to stop -- no errors, the activity just refused to go away no matter how many times stop was clicked.

Opening the picture a second time in the same session caused another instance to open which closed correctly. The first instance still wouldn't close.

There are some failed assertions related to shutting down, see attached WebActivity-nostop.log file.

I restarted and could not reproduce. The log contains similar assertions and an exception(!) on shutdown. See WebActivity-stopped.log

Attachments (2)

WebActivity-nostop.log (1.7 KB) - added by carrott 9 years ago.
webactivity opened a picture and refused to stop
WebActivity-stopped.log (2.5 KB) - added by carrott 9 years ago.
webactivity opened a picture and had an exception during shutdown (shutdown appears to have worked)

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by carrott

webactivity opened a picture and refused to stop

Changed 9 years ago by carrott

webactivity opened a picture and had an exception during shutdown (shutdown appears to have worked)

comment:1 Changed 9 years ago by sascha_silbe

  • Component changed from untriaged to sugar-toolkit
  • Owner set to erikos
  • Severity changed from Unspecified to Minor
  • Version changed from Unspecified to 0.84.x

Assigning to sugar-toolkit because the exceptions all happen there. Seems to be shutdown / garbage collection related.
Not sure if there's a causal relation between the exceptions and the hang. The next time this happens, please attach first strace and later gdb to the process to see it's doing.

comment:2 Changed 6 years ago by dnarvaez

  • Component changed from sugar-toolkit to Sugar

comment:3 Changed 6 years ago by dnarvaez

  • Resolution set to obsolete
  • Status changed from new to closed

very old, not reproducable

Note: See TracTickets for help on using tickets.