Opened 9 years ago

Closed 9 years ago

#2251 closed defect (fixed)

physics on os373pyg on XO-1.5 missing the stop button

Reported by: carrott Owned by: garycmartin
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Physics Version: Unspecified
Severity: Unspecified Keywords: dextrose
Cc: Distribution/OS: Unspecified
Bug Status: Assigned

Description

Physics on os373pyg on the XO-1.5 is missing the stop button, it's hiding in a little drop down menu. There is space to fit it on the toolbar. See attached screenshot.

Attachments (1)

Screenshot of _Physics_.png (33.6 KB) - added by carrott 9 years ago.
physics with stop in drop down

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by carrott

physics with stop in drop down

comment:1 Changed 9 years ago by garycmartin

  • Bug Status changed from Unconfirmed to Assigned
  • Status changed from new to accepted

Thanks for the report. Dang now how did that start happening, been pretty well tested I thought. We've had a couple of cases with other activities like this before. There's does seem to be an overflow miscalculation triggering the dropdown menu too early, when there is enough space for the button. I'll release a minor fix to Physics for now (basically will have to just drop one of the divider separators), and try and see if any progress was made in the more general Sugar case.

comment:2 Changed 9 years ago by garycmartin

  • Resolution set to fixed
  • Status changed from accepted to closed

Problem was caused by the hidden expanding separator that is used to align the Stop button to the right edge of the screen. Even though the separator is invisible, it was taking up space and causing a toolbar overflow, setting separator.set_size_request(0, -1) resolves the issue. Will release a new version of Physics shortly. Should make sure we use this recipe in other activities.

Note: See TracTickets for help on using tickets.