Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#2201 closed defect (obsolete)

Clipboard menu off screen

Reported by: tonyforster Owned by: erikos
Priority: Low Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords: dextrose r?
Cc: alsroot, erikos, sascha_silbe, m_anish, ajay_garg Distribution/OS: Fedora
Bug Status: New

Description

With long text strings in clipboard, the clipboard menu labels are off screen (presumably the menu box is centred), also often the menu is vertically displaced and cannot be reached

os373pyg

Attachments (3)

Screenshotclipboard.png (107.1 KB) - added by tonyforster 9 years ago.
Clipboard.png (126.9 KB) - added by mikus 8 years ago.
Shell.log (94.9 KB) - added by mikus 8 years ago.
FYI. Appears to show nothing unusual regarding the #2201 problem.

Download all attachments as: .zip

Change History (15)

Changed 9 years ago by tonyforster

comment:1 Changed 9 years ago by seeta

  • Status changed from new to assigned

Changed 8 years ago by mikus

comment:2 Changed 8 years ago by mikus

Reproduced on 0.90 -- XO-1 (F14) sugar 0.90-2

What is particularly irksome is that the menu (palette) might be opened at the top of the screen, even though the hovered-over icon might be at the bottom of the screen. This requires a LIGHTNING-FAST cursor movement from icon to palette -- else sugar detects that the cursor has left the icon and stops displaying the menu (palette) -- meaning a slow user can't access the palette.

Even if the user reaches the menu, the other part of the problem is that if he can't see the menu (palette) text, he has to guess which menu line (once hilited) he wants to click on.

Changed 8 years ago by mikus

FYI. Appears to show nothing unusual regarding the #2201 problem.

comment:4 Changed 7 years ago by ajay_garg

  • Bug Status changed from Unconfirmed to New
  • Cc erikos sascha_silbe added
  • Distribution/OS changed from Unspecified to Fedora
  • Milestone changed from Unspecified by Release Team to 0.98
  • Resolution set to fixed
  • Status changed from assigned to closed
  • Version changed from Unspecified to Git as of bugdate

The patchwork links are ::
http://patchwork.sugarlabs.org/patch/534/
http://patchwork.sugarlabs.org/patch/536/

Tested the two patches (in as such forms), by applying them on sugar(mainline, master), and sugar-toolkit(mainline, master) respectively. It worked as expected.

The only thing that annoyed me a bit was that I could not reproduce the problem :D
So, I modified "line 166 of /sugar/src/jarabe/frame/clipboardmenu.py" from

name = self._cb_object.get_name()

to

name = 'veryyyyyyyyyyyyyyyyyyyyyyyy veryyyy veryyyyyyyyyyyyyyy veryyyyy arbittt longggg nameee'

and then I could reproduce the problem, as detailed by tonyforster, and mikus.

After applying the patches, the text was appropriately ellipsized, and the palette did not shoot over to the top.

CCing erikos, and sascha.

If good enough, these two patches could be pushed (after fixing the typo).

erikos, kindly reply with comments :D :D

comment:5 Changed 7 years ago by ajay_garg

  • Resolution fixed deleted
  • Status changed from closed to reopened

Oops.. did not know that this would get closed :|

Re-opening, as I guess that the status would be mark closed, only after it is "pushed".

comment:6 Changed 7 years ago by ajay_garg

  • Owner changed from tomeu to erikos
  • Status changed from reopened to assigned

comment:7 Changed 7 years ago by ajay_garg

One last thing,
THE PATCHES HAVE BEEN TESTED BY ME FEDORA-17, BETA-2.

comment:8 Changed 7 years ago by ajay_garg

  • Cc m_anish ajay_garg added

comment:9 Changed 6 years ago by godiard

  • Priority changed from Unspecified by Maintainer to Low

comment:10 Changed 6 years ago by manuq

  • Resolution set to obsolete
  • Status changed from assigned to closed

I couldn't reproduce the bug in latest Sugar that features GTK+3. Here I provide the details of my test:

Environment: XO-4 with olpc build os22

Testcase 1:

  • open Wikipedia activity
  • click an article with many text, like "Planeta"
  • select a big amount of text, copy it to the clipboard

Testcase 2:

  • open Terminal activity
  • edit a new file with nano editor, write a very long line and save the file
  • read the file with less, select all the text, then copy it to the clipboard

In both cases if I bring up the palette clicking on the clipboard icon, I see the palette in the correct size, the text does ellipsize properly.

If the reporter finds a testcase that makes the bug appear, please write it down in a comment and reopen the ticket.

comment:11 Changed 6 years ago by tonyforster

It looks OK to me too thanks. It looks like it was fixed 8 months ago. I will reopen if I see it again.

comment:12 Changed 6 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.