Opened 9 years ago

Closed 6 years ago

#2156 closed defect (incomplete)

Make palettes lazy

Reported by: erikos Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

We want to make palettes lazy to reduce memory usage.

If the palette needs to be updated (e.g. the palette of an Access POint or Ad-hoc network) we add the logic in a model class that both the icon and the palette listen to and propagating the NM signal with gobject signals or have the icon and palette listening directly to NM, depends how much code is that and how tricky.

Change History (1)

comment:1 Changed 6 years ago by dnarvaez

  • Resolution set to incomplete
  • Status changed from new to closed

Not clear if this refers to specific palettes. I don't think we should do it for every palette because of the increased code complexity.

Note: See TracTickets for help on using tickets.