Opened 11 years ago

Closed 11 years ago

#2082 closed defect (fixed)

mesh icons duplicated on suspend/resume

Reported by: dsd Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: r+
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Three or more mesh icons were being added after every suspend/resume.

There was already code present to detect when the device goes away and
remove the icons, but it was not working. NetworkManagerObserver was
attempting to look at the properties of the gone-away device in order to
see if it is a mesh device, but this was failing because the device has
already been destroyed at this point.

Solve this by recording the device path of the mesh device when it is
detected, so that we can later determine if the gone-away device is the
mesh device.

Attachments (1)

0001-Fix-duplication-of-OLPC-mesh-icons.patch (3.3 KB) - added by dsd 11 years ago.
fix

Download all attachments as: .zip

Change History (4)

comment:1 Changed 11 years ago by dsd

Reviewed by myself (on IRC) and by James Cameron on the mailing list.

comment:2 Changed 11 years ago by tomeu

  • Keywords r+ added; r? removed

Looks great to me as well, please push.

comment:3 Changed 11 years ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

pushed as f1076d654b9100b0e528b201b0aeb468edbd7a26

Note: See TracTickets for help on using tickets.