Opened 9 years ago

Closed 7 years ago

#2060 closed defect (fixed)

Copying files multiple times results in bogus names

Reported by: bernie Owned by: alsroot
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: journal Version: Unspecified
Severity: Unspecified Keywords: dextrose sugar-love dtst
Cc: aa, smparrish, bernie Distribution/OS: Unspecified
Bug Status: Assigned

Description

  1. drag a file from the journal to a volume
  2. drag it again and again
  3. open the volume

The copies will be called foo, foo_1, foo_1_2, foo_1_2_3, and so on.

Change History (12)

comment:1 Changed 9 years ago by alsroot

This is not a bug but a future :) which exists, afaik, for several sugar releases. I guess we need to discuss changing existed behaviour widely on sugar-devel@.

comment:2 Changed 9 years ago by bernie

  • Keywords dextrose sugar-love added

comment:3 Changed 9 years ago by smparrish

  • Cc smparrish added

I agree with alsroot. This is how things work in KDE and Gnome as well to prevent file clobbering.

comment:4 Changed 9 years ago by smparrish

  • seeta_dev set to Ishan

comment:5 Changed 8 years ago by sascha_silbe

  • Cc bernie added

Copying CC list from #2453.

comment:6 Changed 8 years ago by bernie

My description of the problem was probably too vague.

This is the expected naming scheme: foo, foo_1, foo_2, foo_3, foo_4...

This is what we're doing instead: foo, foo_1, foo_1_2, foo_1_2_3, foo_1_2_3_4...

comment:7 follow-up: Changed 8 years ago by jtannenbaum

patch (untested): http://pastebin.com/b5Km4EB4

note: first patch ever, expect catastrophic embarrassment

comment:8 in reply to: ↑ 7 Changed 8 years ago by sascha_silbe

Replying to jtannenbaum:

patch (untested): http://pastebin.com/b5Km4EB4

note: first patch ever, expect catastrophic embarrassment

Thanks for the patch! However there already is a patch for this issue, it just needs a clean-up of the authorship.

comment:9 Changed 8 years ago by smparrish

  • Bug Status changed from Unconfirmed to Assigned
  • Keywords dst added

This patch has been included in os5dx2 release of Dextrose

comment:10 Changed 8 years ago by smparrish

  • Keywords dtst added; dst removed

comment:11 follow-up: Changed 7 years ago by godiard

The patch was already commited in Nov 24 2010 569c713e8300da659234b2192c78a1343f032144

Can we close this ticket?

comment:12 in reply to: ↑ 11 Changed 7 years ago by bernie

  • Resolution set to fixed
  • Status changed from new to closed

Replying to godiard:

The patch was already commited in Nov 24 2010 569c713e8300da659234b2192c78a1343f032144

Can we close this ticket?

Sure. When you feel like closing a bug, you can just go ahead and do it. If the reporter or owner disagree, they can reopen it later.

Note: See TracTickets for help on using tickets.