Opened 11 years ago

Closed 10 years ago

Last modified 7 years ago

#1853 closed defect (fixed)

Redunant code /jarabe/view/viewsource.py

Reported by: timclicks Owned by: timClicks
Priority: Low Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Trivial Keywords: r+
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Toolbarstop, a gtk.ToolButton, had its show() method called twice. Patch removes the first one, which is called before the stop has been inserted into the toolbar. Have manually tested.

Output of git format-patch:

From 5cd8085667d2d60cbf6a8f6d0987bd1458dc99df Mon Sep 17 00:00:00 2001
From: timClicks <paperless@timmcnamara.co.nz>
Date: Sun, 21 Mar 2010 12:39:15 +1300
Subject: [PATCH] Removed redundancy

Toolbarstop, a gtk.ToolButton, had its show() method called
twice. Removed the first one.
---
 src/jarabe/view/viewsource.py |    1 -
 1 files changed, 0 insertions(+), 1 deletions(-)

diff --git a/src/jarabe/view/viewsource.py b/src/jarabe/view/viewsource.py
index 9905713..290df18 100644
--- a/src/jarabe/view/viewsource.py
+++ b/src/jarabe/view/viewsource.py
@@ -309,7 +309,6 @@ class Toolbar(gtk.Toolbar):
         stop = ToolButton(icon_name='dialog-cancel')
         stop.set_tooltip(_('Close'))
         stop.connect('clicked', self.__stop_clicked_cb)
-        stop.show()
         self.insert(stop, -1)
         stop.show()
 
-- 
1.6.3.3

Change History (3)

comment:1 Changed 11 years ago by sascha_silbe

  • Keywords r? added
  • Milestone changed from Unspecified by Release Team to 0.90
  • Owner changed from tomeu to timClicks
  • Priority changed from Unspecified by Maintainer to Low
  • Status changed from new to assigned

Tim, thanks for the patch!
Please see Code Review for how to submit future patches. In particular, please attach the file instead of pasting it inline (because cut&paste converts whitespaces, so can break the patch) and set the "r?" keyword to make it enter the review "queue". I'm aware the current process is a bit cumbersome, especially for small patches; we're working on improving it.
The patch itself looks good to me.

comment:2 Changed 10 years ago by tomeu

  • Keywords r+ added; r? removed
  • Resolution set to fixed
  • Status changed from assigned to closed

Pushed, thanks!

comment:3 Changed 7 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.