Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1745 closed defect (duplicate)

OperationalError: database is locked

Reported by: tabitha Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: bugs.sugarlabs.org Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

How to Reproduce

While doing a POST operation on /login, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'0fd150aacc4ce1151bb54fae',
 'password': u'jonina',
 'referer': u'http://trac.sugarlabs.org/',
 'user': u'tabitha'}

User Agent was: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

System Information

Trac 0.11.6
Python 2.5.2 (r252:60911, Jan 21 2010, 04:10:42)
[GCC 4.2.4 (Ubuntu 4.2.4-1ubuntu3)]
setuptools 0.6c8
SQLite 3.4.2
pysqlite 2.3.2
Genshi 0.5.1
CustomFieldAdmin 0.2.2
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/web/main.py", line 206, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-sparc64/egg/acct_mgr/web_ui.py", line 463, in process_request
    return auth.LoginModule.process_request(self, req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/web/auth.py", line 104, in process_request
    self._redirect_back(req)
  File "build/bdist.linux-sparc64/egg/acct_mgr/web_ui.py", line 485, in _redirect_back
    req.redirect(referer or self.env.abs_href())
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/web/api.py", line 305, in redirect
    self.session.save() # has to be done before the redirect is sent
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/web/session.py", line 127, in save
    (self.last_visit, self.sid, authenticated))
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/db/util.py", line 64, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/db/sqlite_backend.py", line 80, in execute
    PyFormatCursor.execute(self, *args)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/db/sqlite_backend.py", line 59, in execute
    args or [])
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/db/sqlite_backend.py", line 51, in _rollback_on_error
    return function(self, *args, **kwargs)
OperationalError: database is locked


Change History (2)

comment:1 Changed 9 years ago by sascha_silbe

  • Component changed from sugar to trac
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #698.

comment:2 Changed 9 years ago by sascha_silbe

Oh, and you will most likely want to change your password, Tabitha. It was contained in the above output.

Note: See TracTickets for help on using tickets.