Opened 9 years ago

Closed 9 years ago

#1707 closed defect (duplicate)

Record-64 segfaults on startup under Fedora 12 32-bit

Reported by: DeanBrettle Owned by: alsroot
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Record Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Fedora
Bug Status: Needinfo

Description

I suspect a header changed in one of the dependencies required to build camera.so, because I was able to fix this with:

cd ~/Activities/Record.activity/camerac
rm -rf linux*
su -c 'yum install gcc glib2-devel gtk2-devel pygtk2-devel cairo-devel pycairo-devel'
make

Attachments (1)

rpms.txt (72.1 KB) - added by DeanBrettle 9 years ago.
Output of rpm -qa on my Fedora 12 system

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by alsroot

  • Resolution set to wontfix
  • Status changed from new to closed

Thanks but current Record won't work in f12's sugar anyway - there are bunch of window related issues. There are plans to implement more window less scheme and switch Record to camerabin gst pluging (thus remove camerac) instead of complicated gst code. So, Record was marked only for 0.82-0.84 sugars (and should work fine in systems that have these sugars).

comment:2 follow-up: Changed 9 years ago by DeanBrettle

I didn't see any tickets open for the window related issues? Can you point me to more details on them? It looked to me like it was working fine with one minor exception -- I had to switch to Image and then back to Video to get back to recording after playing back a video.

comment:3 in reply to: ↑ 2 Changed 9 years ago by alsroot

Replying to DeanBrettle:

I didn't see any tickets open for the window related issues? Can you point me to more details on them? It looked to me like it was working fine with one minor exception -- I had to switch to Image and then back to Video to get back to recording after playing back a video.

Are you using 0.86+ sugar? In my case Record-64 is pretty unusable(all windows are misplaced and switching doesn't help). Current Record's code is stuck to subwindows design that's why idea was to implement simple widget based design.

comment:4 follow-up: Changed 9 years ago by DeanBrettle

sugar-0.86.3-1.fc12.i686

With the aforementioned fix Record is definitely usable.

comment:5 in reply to: ↑ 4 Changed 9 years ago by alsroot

  • Bug Status changed from Unconfirmed to Needinfo
  • Resolution wontfix deleted
  • Status changed from closed to reopened

Replying to DeanBrettle:

sugar-0.86.3-1.fc12.i686

With the aforementioned fix Record is definitely usable.

hmm.. I've just rechecked Record-64 from ASLO and it still doesn't work in my case, so I guess it couldn't be marked ready for 0.86 but at least new binary blobs could be bundled to work well in f12.

I'm working on 0install integration and will bundle new blobs for Record, could you attach list of your current rpms rpm -qa

Changed 9 years ago by DeanBrettle

Output of rpm -qa on my Fedora 12 system

comment:6 follow-up: Changed 9 years ago by DeanBrettle

Done. What distro are you running?

comment:7 in reply to: ↑ 6 Changed 9 years ago by alsroot

Replying to DeanBrettle:

Done. What distro are you running?

Gentoo.. and looks like I had the same versions..

comment:8 Changed 9 years ago by alsroot

  • Resolution set to duplicate
  • Status changed from reopened to closed

I'm planing to refactor Record code in #1847 and #1848 and v65 will be pretty different, please recheck this issue in v65 which will appear after closing these two bugs.

Note: See TracTickets for help on using tickets.