Opened 11 years ago

Closed 10 years ago

#1697 closed defect (duplicate)

Error during phase build of python-xklavier

Reported by: RafaelOrtiz Owned by: sascha_silbe
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: sugar-jhbuild Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Ubuntu
Bug Status: Unconfirmed

Description

While running sugar-jhbuild on ubuntu-lucid

Error running make [8/40]

Change History (3)

comment:1 Changed 11 years ago by sascha_silbe

  • Resolution set to incomplete
  • Status changed from new to closed

Closing due to lack of detail. If this still happens for you please reopen and paste the actual error message. If in doubt, attach the entire log.

comment:2 Changed 10 years ago by nikhilmitra

  • Resolution incomplete deleted
  • Status changed from closed to reopened

here's the part of log when I encountered the error,

Now type `make' to compile python-xklavier
*** Cleaning python-xklavier *** [6/32]
make   clean
Making clean in xklavier
make[1]: Entering directory `/home/nikhil/sugar-jhbuild/source/python-xklavier/xklavier'
test -z "xklavier.c" || rm -f xklavier.c
rm -rf .libs _libs
test -z "xklavier.la" || rm -f xklavier.la
rm -f "./so_locations"
rm -f *.o
rm -f *.lo
make[1]: Leaving directory `/home/nikhil/sugar-jhbuild/source/python-xklavier/xklavier'
Making clean in .
make[1]: Entering directory `/home/nikhil/sugar-jhbuild/source/python-xklavier'
rm -rf .libs _libs
rm -f *.lo
make[1]: Leaving directory `/home/nikhil/sugar-jhbuild/source/python-xklavier'
*** Building python-xklavier *** [6/32]
make  
make  all-recursive
make[1]: Entering directory `/home/nikhil/sugar-jhbuild/source/python-xklavier'
Making all in xklavier
make[2]: Entering directory `/home/nikhil/sugar-jhbuild/source/python-xklavier/xklavier'
/bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -I/usr/include/python2.6 -pthread -I/usr/include/pygtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include     -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2   -pthread -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12   -g -O2 -MT xklavier_la-xklaviermodule.lo -MD -MP -MF .deps/xklavier_la-xklaviermodule.Tpo -c -o xklavier_la-xklaviermodule.lo `test -f 'xklaviermodule.c' || echo './'`xklaviermodule.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -I/usr/include/python2.6 -pthread -I/usr/include/pygtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -pthread -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -g -O2 -MT xklavier_la-xklaviermodule.lo -MD -MP -MF .deps/xklavier_la-xklaviermodule.Tpo -c xklaviermodule.c  -fPIC -DPIC -o .libs/xklavier_la-xklaviermodule.o
mv -f .deps/xklavier_la-xklaviermodule.Tpo .deps/xklavier_la-xklaviermodule.Plo
(cd . \
	 && /usr/bin/pygobject-codegen-2.0 \
	    --override xklavier.override \
	    --prefix xklavier xklavier.defs) > gen-xklavier.c \
	&& cp gen-xklavier.c xklavier.c \
	&& rm -f gen-xklavier.c
Warning: generating old-style constructor for:xkl_config_registry_get_instance
Could not write function void: No ArgType for *
Could not write function xkl_default_log_appender: No ArgType for va_list
Could not write function xkl_set_log_appender: No ArgType for XklLogAppender
Could not write function void: No ArgType for *
Could not write function void: No ArgType for *
Could not write function xkl_engine_INT__LONG_LONG: No ArgType for GValue*
Could not write function xkl_engine_VOID__FLAGS_INT_BOOLEAN: No ArgType for GValue*
Warning: Constructor for XklConfigRegistry needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
***INFO*** The coverage of global functions is 30.00% (3/10)
***INFO*** The coverage of methods is 100.00% (58/58)
***INFO*** There are no declared virtual proxies.
***INFO*** There are no declared virtual accessors.
***INFO*** There are no declared interface proxies.
/bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -I/usr/include/python2.6 -pthread -I/usr/include/pygtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include     -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2   -pthread -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12   -g -O2 -MT xklavier_la-xklavier.lo -MD -MP -MF .deps/xklavier_la-xklavier.Tpo -c -o xklavier_la-xklavier.lo `test -f 'xklavier.c' || echo './'`xklavier.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -I/usr/include/python2.6 -pthread -I/usr/include/pygtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -pthread -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -g -O2 -MT xklavier_la-xklavier.lo -MD -MP -MF .deps/xklavier_la-xklavier.Tpo -c xklavier.c  -fPIC -DPIC -o .libs/xklavier_la-xklavier.o
xklavier.c: In function ‘_wrap_xkl_engine_get_backend_name’:
xklavier.c:1181: warning: assignment discards qualifiers from pointer target type
xklavier.c: In function ‘_wrap_xkl_engine_stop_listen’:
xklavier.c:1246: error: too few arguments to function ‘xkl_engine_stop_listen’
xklavier.override: In function ‘_wrap_xkl_engine_get_groups_names’:
xklavier.override:160: warning: assignment from incompatible pointer type
xklavier.override: In function ‘_wrap_xkl_engine_get_indicators_names’:
xklavier.override:179: warning: assignment from incompatible pointer type
make[2]: *** [xklavier_la-xklavier.lo] Error 1
make[2]: Leaving directory `/home/nikhil/sugar-jhbuild/source/python-xklavier/xklavier'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/nikhil/sugar-jhbuild/source/python-xklavier'
make: *** [all] Error 2
*** Error during phase build of python-xklavier: ########## Error running make   *** [6/32]

comment:3 Changed 10 years ago by sascha_silbe

  • Resolution set to duplicate
  • Status changed from reopened to closed

Dupe of #1942.

Note: See TracTickets for help on using tickets.