Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#1692 closed defect (wontfix)

Add sugar-settings-manager

Reported by: sayamindu Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: r!
Cc: sdz, erikos Distribution/OS: Unspecified
Bug Status: New

Description

The code for sugar-settings-manager lives in
http://git.sugarlabs.org/projects/sugar-settings-manager

Patch for starting up the manager:

diff --git a/bin/sugar.in b/bin/sugar.in
index 498b573..813b189 100644
--- a/bin/sugar.in
+++ b/bin/sugar.in
@@ -36,6 +36,8 @@ while [ $# -ne 0 ] ; do
     shift
 done
 
+sugar-settings-manager &
+
 if test -z "$SUGAR_SCALING"; then
     export SUGAR_SCALING=72
 fi

Attachments (2)

sugar-jhbuild-settings-manager.patch (966 bytes) - added by sayamindu 9 years ago.
Patch for sugar-jhbuild
sugar-toolkit-dont-configure-fonts.patch.gz (450 bytes) - added by sayamindu 9 years ago.
Patch for sugar-toolkit

Download all attachments as: .zip

Change History (11)

Changed 9 years ago by sayamindu

Patch for sugar-jhbuild

comment:1 Changed 9 years ago by sayamindu

  • Keywords r? added

comment:2 Changed 9 years ago by sayamindu

Patch against sugar-toolkit is at http://pastebin.be/23210 (Trac won't let me attach it since it thinks it is spam)

comment:3 Changed 9 years ago by tomeu

  • Keywords r! added; r? removed

I think that we should have a release of settings-manager before sugar can depend on it. Also, are you going to maintain that module in sugar? Or as an external dependency?

comment:4 Changed 9 years ago by sayamindu

I can do a release immediately. Which makes more sense - as a submodule inside sugar, or as an external project.

Changed 9 years ago by sayamindu

Patch for sugar-toolkit

comment:5 follow-up: Changed 9 years ago by sdz

  • Cc sdz erikos added

What's the best way to proceed here? We got it reviewed and built in Fedora so far. So should we temporarily apply these two patches?

comment:6 in reply to: ↑ 5 Changed 9 years ago by tomeu

Replying to sdz:

What's the best way to proceed here? We got it reviewed and built in Fedora so far. So should we temporarily apply these two patches?

If you really want, sure. But the reason why upstream Sugar is not depending on the settings-manager yet is because we don't have any UI yet for changing the font size, so it wouldn't bring us any benefit. But it may land in a later 0.88 minor release if a deployment asks strongly for it.

comment:7 Changed 9 years ago by erikos

  • Bug Status changed from Unconfirmed to New
  • Milestone changed from Unspecified by Release Team to 0.90

I move this to 0.90. If a deployment cares strongly for this to be present, we can move it to 0.88.x. Please comment in this ticket, if.

comment:8 Changed 6 years ago by dnarvaez

  • Resolution set to wontfix
  • Status changed from new to closed

After 3 years it seems we lost the train on this, also I have the feeling gtk is moving away from settings manager these days.

comment:9 Changed 6 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.