Opened 11 years ago

Closed 9 years ago

Last modified 8 years ago

#1691 closed defect (duplicate)

Ubuntu dropped python-xpcom

Reported by: HoboPrimate Owned by: sascha_silbe
Priority: Normal Milestone:
Component: sugar-jhbuild Version: Git as of bugdate
Severity: Major Keywords:
Cc: Distribution/OS: Ubuntu
Bug Status: Assigned

Description

I'm running sugar-jhbuild on Ubuntu Karmic. This behaviour has existed for months, so finally I've decided to file a ticket for it :)

This is Browse's log:

(process:5636): Gtk-WARNING : Locale not supported by C library.

Using the fallback 'C' locale.

(sugar-activity:5636): atk-bridge-WARNING : AT_SPI_REGISTRY was not started at session startup.

(sugar-activity:5636): atk-bridge-WARNING : IOR not set.

(sugar-activity:5636): atk-bridge-WARNING : Could not locate registry
/home/jobezone/devel/sugar-jhbuild/install/share/sugar/activities/Browse.activity/webactivity.py:26: DeprecationWarning: the sha module is deprecated; use the hashlib module instead

import sha

/home/jobezone/devel/sugar-jhbuild/install/share/sugar/activities/Browse.activity/webactivity.py:37: Warning: g_set_prgname() called multiple times

gnome.init('Hulahop', '1.0')

returning /home/jobezone/.sugar/default/org.laptop.WebActivity/data/gecko/prefs.js for key NS_APP_PREFS_50_FILE
Traceback (most recent call last):

File "/home/jobezone/devel/sugar-jhbuild/install/bin/sugar-activity", line 21, in <module>

main.main()

File "/home/jobezone/devel/sugar-jhbuild/install/lib/python2.6/site-packages/sugar/activity/main.py", line 118, in main

module = import(module_name)

File "/home/jobezone/devel/sugar-jhbuild/install/share/sugar/activities/Browse.activity/webactivity.py", line 132, in <module>

hulahop.startup(_profile_path)

File "/home/jobezone/devel/sugar-jhbuild/install/lib/python2.6/site-packages/hulahop/init.py", line 56, in startup

from xpcom import components

ImportError: No module named xpcom
1264641570.405601 DEBUG root: _cleanup_temp_files
Activity died: pid 5636 condition 256 data (None, <open file '<fdopen>', mode 'w' at 0xab74d90>)

Change History (12)

comment:1 follow-up: Changed 11 years ago by RafaelOrtiz

  • Resolution set to notsugar
  • Status changed from new to closed

Yes, this is known, in ubuntu we have the problem that upstream is deciding how to work with xulrunner..so this is not sugar related.

in relation with ubuntu bugs please refer to https://launchpad.net/~sugarteam

comment:2 Changed 11 years ago by RafaelOrtiz

And thanks for reporting this!

comment:3 in reply to: ↑ 1 Changed 11 years ago by sascha_silbe

  • Bug Status changed from Unconfirmed to Assigned
  • Priority changed from Unspecified by Maintainer to Normal
  • Resolution notsugar deleted
  • Severity changed from Unspecified to Major
  • Status changed from closed to reopened
  • Summary changed from Browse doesn't start on up-to-date sugar-jhbuild to Ubuntu dropped python-xpcom

Replying to RafaelOrtiz:

Yes, this is known, in ubuntu we have the problem that upstream is deciding how to work with xulrunner..so this is not sugar related.

Actually for karmic the problem is "just" that the python-xpcom part got dropped from the xulrunner source package (by Mozilla) and Ubuntu did not yet package it separately (LP#480407).

in relation with ubuntu bugs please refer to https://launchpad.net/~sugarteam

As this bug was encountered with sugar-jhbuild (not native Ubuntu package) this is exactly the right place to report bugs.

Reopening as we need to adopt sugar-jhbuild dependency files once Ubuntu ships python-xpcom again.
We should also build python-xpcom from source in the meantime, but I don't have time to set this up right now (patches welcome) - Mozilla software has a history of being tricky to build.

comment:4 Changed 11 years ago by sascha_silbe

  • Component changed from Browse to sugar-jhbuild
  • Milestone changed from Unspecified by Release Team to not applicable
  • Owner changed from erikos to sascha_silbe
  • Status changed from reopened to assigned

comment:5 Changed 11 years ago by RafaelOrtiz

Ok fair enough, David is also in contact with the developer of ubuntu who maintains mozilla.

comment:6 Changed 11 years ago by RafaelOrtiz

mozilla packages for being more explicit.

comment:7 Changed 11 years ago by HoboPrimate

Any update on this "bug"? It is the only thing keeping me from using Sugar-jhbuild (to use the environment the most, so as to find bugs, UI issues, etc.)

comment:8 Changed 11 years ago by HoboPrimate

To others, here's the hack I did: Go to http://packages.debian.org/squeeze/python-xpcom and download and install the debian package. It may conflict with epiphany-browser, in which case you have first to remove it.

comment:9 Changed 9 years ago by sascha_silbe

  • Resolution set to duplicate
  • Status changed from assigned to closed

Dupe of #791.

comment:10 Changed 9 years ago by sascha_silbe

Sorry for the typo. This bug is a dupe of 729.

comment:11 Changed 9 years ago by sascha_silbe

comment:12 Changed 8 years ago by dnarvaez

  • Milestone not applicable deleted

Milestone not applicable deleted

Note: See TracTickets for help on using tickets.