Opened 11 years ago

Closed 11 years ago

#1689 closed defect (fixed)

firefox 3.5 and 3.6 blur on the XO

Reported by: BryanWB Owned by: erikos
Priority: High Milestone: Unspecified
Component: Browse Version: 0.82.x
Severity: Critical Keywords:
Cc: mikus Distribution/OS: OLPC
Bug Status: Resolved

Description

I have tested firefox 3.5 and 3.6 on the XO-1 with Sugar version sugar-0.81.7-1.

I tested with vanilla firefox 3.6 on 0.81.7-1 and w/ Browse on os10 (see below)
You can test using this web page
http://karma.sugarlabs.org/examples/English_Animal_Identification/index.html

I see significant blurring whenever a png image is added for manipulated

I also had this issue w/ os10 (v0.84?)
http://dev.laptop.org/~smparrish/XO-1/builds/OS10/

Attachments (7)

firefox-3-6-blur1.png (126.1 KB) - added by BryanWB 11 years ago.
firefox-3-6-blur2.png (125.2 KB) - added by BryanWB 11 years ago.
karma-template1.png (157.9 KB) - added by BryanWB 11 years ago.
tiger.png (117.4 KB) - added by mikus 11 years ago.
Firefox 3.6b4 on XO_1 with os11. Didn't see any "blurring".
top-blurring.png (319.0 KB) - added by BryanWB 11 years ago.
blurred-buttons.png (70.4 KB) - added by BryanWB 11 years ago.
the buttons blur on mouseover
Firefox-bef.png (310.9 KB) - added by mikus 11 years ago.
soas04xo - slight "blurring" behind help button

Download all attachments as: .zip

Change History (23)

Changed 11 years ago by BryanWB

Changed 11 years ago by BryanWB

Changed 11 years ago by BryanWB

comment:1 follow-up: Changed 11 years ago by quozl

How is this a problem with Sugar?

I've tested the page you refer to:

http://karma.sugarlabs.org/examples/English_Animal_Identification/index.html

modelbuildsoftwareresult
XO-1OLPC 802Browse-102 on Sugar 0.82.9no blur, but no buttons
XO-1DebXO 0.5 GNOMEEpiphanyno blur
XO-1.5os108Browse-108 on Sugar 0.84.10no blur, good buttons
XO-1.5os108Firefox 3.5.6no blur, good buttons

So far I'm unable to reproduce the pixel damage you show in your attachments. Have you considered the possibility of hardware failure, and have you tried another XO?

comment:2 in reply to: ↑ 1 Changed 11 years ago by BryanWB

Replying to quozl:

How is this a problem with Sugar?

I've tested the page you refer to:

http://karma.sugarlabs.org/examples/English_Animal_Identification/index.html

modelbuildsoftwareresult
XO-1OLPC 802Browse-102 on Sugar 0.82.9no blur, but no buttons
XO-1DebXO 0.5 GNOMEEpiphanyno blur
XO-1.5os108Browse-108 on Sugar 0.84.10no blur, good buttons
XO-1.5os108Firefox 3.5.6no blur, good buttons

So far I'm unable to reproduce the pixel damage you show in your attachments. >Have you considered the possibility of hardware failure, and have you tried another XO?

I have not tried on another XO. I assumed that since firefox 3.0 doesn't have issues that it is a software problem and not a hardware problem. I will try out another XO tomorrow. Great suggestion.

The images that are distorted are 'tiled' images. That is they are small images that are repeated in a given direction. I turned off the tiling by setting css property background-repeat: no-repeat;

then set:
-moz-background-size: 100% 100%;

and voila, looks lovely

According to Cork on #firefox mozilla network, some lower level library than firefox is providing incorrect dimensions. Or, it could be that my hardware is at fault.

I will also try firefox-3.5 again and check the results

comment:3 Changed 11 years ago by BryanWB

yup, same problem w/ firefox 3.5.3

So need to test on a different machine

comment:4 Changed 11 years ago by BryanWB

tried on different XO but have same problem.

comment:5 Changed 11 years ago by mikus

  • Cc mikus added

I see significant blurring whenever a png image is added for manipulated

Not sure what you mean -- are you referring to the additional white marks within the purple/brown area at the bottom of your examples ?

I have been using Firefox 3.5/3.6 for months on my XOs (currently I'm on 3.6b4). I have NEVER seen visual artifacts that I would describe as "blurring". [Admittedly, I have gone out of my way to define for X a giant assortment of Unicode fonts !]

My principal problem with Firefox is that the "canvas" on which it renders the content is much larger than the XO screen dimensions. Haven't gotten around to try to fix that.

Attached is a screenshot taken in Firefox on XO-1 with os11.

Changed 11 years ago by mikus

Firefox 3.6b4 on XO_1 with os11. Didn't see any "blurring".

comment:6 Changed 11 years ago by BryanWB

Mikus, pls try mousing over the back button and the help button and tell me if u see any blurring. I do see blurring of those w/ os10 which is F11-based. While I don't see blurring of the bottom, I do see blurring on the top, particularly when the buttons are moused over, which causes image replacement
http://dev.laptop.org/~smparrish/XO-1/builds/OS10/

I do see substantial blurrin w/ os10 on my XO, which makes me think this is a problem that affects all Sugar versions. I haven't yet tested soas due to my damn slow Internet connection. Hope to have that by tomorrow

See attached images for examples of blurring

Changed 11 years ago by BryanWB

Changed 11 years ago by BryanWB

the buttons blur on mouseover

comment:7 Changed 11 years ago by mikus

From your 'top-blurring.png' attachment, I see that by "blurring" you do mean the additional white marks (which in that .png appear in the top area). No - I have not seen any corruption like your white marks.

When I mouse over the back button or the help button, all that happens is that a blue circle gets drawn around the button that I am mousing over. I do NOT see any corruption ("blurring") anywhere.

It was viewing Tomeu's post on devel@… that directed me to your ticket. He was talking about running Firefox in gnome on the XO. So this time, I ran Firefox in gnome on XO-1 (os11) and in gnome on XO-1.5 (os109). The only difference that I can see (between on gnome and on sugar) is that the Firefox title bars appear slimmer in the gnome environment than in the sugar environment. [Having the Firefox "canvas" extend beyond the XO screen size - appears to occur the same in the gnome environment as in the sugar environment.]

Again -- in months of using (in the sugar environment) Firefox 3.5/3.6 on XOs, I have never experienced "blurring" (corruption). [Though normally I run only Activities when using SoaS builds on an XO -- the (additional) browsers I install myself (such as the non-Activity Firefox) I'll typically run only while using laptop.org builds.]

comment:8 Changed 11 years ago by mikus

The most recent SoaS build that I have installad into the NAND on an XO is 'soas04xo'. [I do not bother to "customize" (e.g., by installing additional browsers) builds which I have to boot from an USB stick.] Note: recently, after applying an xorg update (for F12) to my soas04xo system, I experienced video corruption - for instance, the initial rendering of Home View did not show icons in the ring -- what I saw instead was black squares in those icon positions. My bypass was to import /etc/X11/xorg-dcon.conf from an os10 build -- then that "unwanted black" corruption went away.

Just now tested Firefox 3.6b4 on soas04xo with your page -- and did see a bit of what you call "blurring". When I moused over the back button or the help button, the blue circle got properly drawn around the button -- but the square area behind the respective button+circle appeared (usually, but not always) to be corrupted with some white marks. Never saw white marks within the rest of the area at the top, nor within the purple/brown area near the bottom.

comment:9 Changed 11 years ago by BryanWB

see, I am not crazy ;)

comment:10 follow-ups: Changed 11 years ago by garycmartin

Sorry to be late on this, but the title 'blur' didn't make me take note. Looking at the images this looks just like an old image corruption glitch going way back as far as I recall. I used to show up on a few web pages, but the obvious one was the submit button for the 'get developer key' page. Just looking for the old tickets... http://dev.laptop.org/ticket/8760 http://dev.laptop.org/ticket/7830

There was simple fix but I'm not sure it ever made it into an official build. The corruption issue went away for me on XO-1s by adding Option "NoAccel" "true" in the device section to the /etc/X11/xorg.conf

comment:11 in reply to: ↑ 10 Changed 11 years ago by sascha_silbe

Replying to garycmartin:

There was simple fix but I'm not sure it ever made it into an official build.

The fix was for another bug reported in the same ticket. It has made it upstream as of 2.11.1 so cannot be the issue Bryan encounters.
Upstream has switched the default from EXA to XAA for 2.11.4 (F11 has 2.11.2) exactly because EXA support is known to be broken. As the LX driver only supports EXA this is probably equivalent to NoAccel so it makes sense to use the latter option for F11-on-XO1. :-/

Changed 11 years ago by mikus

soas04xo - slight "blurring" behind help button

comment:12 Changed 11 years ago by mikus

In soas04xo, tried adding Option "NoAccel" "true" in the device section of the /etc/X11/xorg.conf that I had copied from an os10 system (originally, soas04xo came without any xorg.conf). Having the "NoAccel" option there prevented the system from booting - X was getting a segment fault. [I don't have the time to follow this up.] Had to take the Option "NoAccel" "true" line out.

comment:13 in reply to: ↑ 10 ; follow-up: Changed 11 years ago by BryanWB

Replying to garycmartin:

Sorry to be late on this, but the title 'blur' didn't make me take note. Looking at the images this looks just like an old image corruption glitch going way back as far as I recall. I used to show up on a few web pages, but the obvious one was the submit button for the 'get developer key' page. Just looking for the old tickets... http://dev.laptop.org/ticket/8760 http://dev.laptop.org/ticket/7830

There was simple fix but I'm not sure it ever made it into an official build. The corruption issue went away for me on XO-1s by adding Option "NoAccel" "true" in the device section to the /etc/X11/xorg.conf

Hey Gary, this works for me on Sugar 0.81 for the XO

Is there a performance penalty to turning off hardware acceleration?

comment:14 in reply to: ↑ 13 ; follow-up: Changed 11 years ago by quozl

Replying to BryanWB:

Is there a performance penalty to turning off hardware acceleration?

Yes.

comment:15 in reply to: ↑ 14 Changed 11 years ago by garycmartin

Replying to quozl:

Replying to BryanWB:

Is there a performance penalty to turning off hardware acceleration?

Yes.

The answer is very likely 'yes' but I have to say I never noticed any performance loss from a hands on user perspective (and we have way larger holes to fill there). I think this was part of the reason mentioned not to include such a fix, no one was sure what the impact was. Worked for me, is all I can offer, but be aware I've not tried this on recent Sugar builds so some more testing would be sensible.

comment:16 Changed 11 years ago by BryanWB

  • Bug Status changed from Unconfirmed to Resolved
  • Resolution set to fixed
  • Status changed from new to closed

This fix http://dev.laptop.org/ticket/7830 seems to fix the issue on 0.82

Option "MigrationHeuristic" "greedy"

in the Device section of /etc/X11/xorg.conf seems to fix it though I have not tested it thoroughly

Thanks to dsd for the fix

Note: See TracTickets for help on using tickets.