Opened 11 years ago

Closed 8 years ago

Last modified 8 years ago

#1690 closed enhancement (fixed)

Retain font and size in Write Activity

Reported by: krid Owned by: godiard
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Write Version: Unspecified
Severity: Unspecified Keywords: easy-hack, AU1B
Cc: humitos, godiard Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Dear madam, sir,
The Write Activity has a preset font (Dejavu Serif) and font size (12 pts). The font size is much too small for young students and a serif font is rather unusual when learing to read and write. No reading/writing method in the Neterhlands uses serif fonts and we expect the same in other countries.

Request:
Would it be possible to select font and size _and retain_ them in such a way that at a next startup it is not necessary to set font and size again

This feature would be much appreciated. We know font and size can be hard hard coded on every XO, but those settings are lost with every upgrade.

Thank you in advance for reading our request,
with amicable greetings, and thank you for a great project!

Dirk Schouten
Public Primary School Rosa Boekdrukker
the Netherlands


Attachments (2)

0001-Retain-font-family-and-font-size.patch (5.9 KB) - added by lionaneesh 8 years ago.
Patch, Note: This is a GCI task (http://www.google-melange.com/gci/task/view/google/gci2012/7950210)
0001-Retain-font-family-and-font-size.-Fix-1690.patch (6.4 KB) - added by lionaneesh 8 years ago.
Patch for sugar-0.94, Note: This is a GCI task (http://www.google-melange.com/gci/task/view/google/gci2012/7950210)

Download all attachments as: .zip

Change History (14)

comment:1 Changed 11 years ago by tomeu

  • Component changed from sugar to Write

comment:2 Changed 10 years ago by RafaelOrtiz

I agree with the default font size, this should be greater than 12 (at least 14),
what default font should be preferred here talking into account that we must use free fonts?

comment:3 Changed 9 years ago by godiard

  • Keywords easy-hack added

comment:4 Changed 9 years ago by humitos

  • Cc humitos added

comment:5 Changed 9 years ago by humitos

What is the best way to do this?

I'm thinking about save the last Size & Font used by the child in .ini to be parsed with ConfigParser the next time that the Activity is launched.

What's about gconf?

What do you think?

comment:6 follow-up: Changed 9 years ago by godiard

  • Cc godiard added

I propose do the same we are doing in GetBooks activity.

Use a .ini file, but check first if there are a similar file in /etc/

This is useful for deployments to change the config. By example, australia use a particular font.

comment:7 in reply to: ↑ 6 Changed 9 years ago by manuq

Replying to godiard:

I propose do the same we are doing in GetBooks activity.

Use a .ini file, but check first if there are a similar file in /etc/

This is useful for deployments to change the config. By example, australia use a particular font.

+1

comment:8 Changed 9 years ago by sascha_silbe

There was some discussion about this on iaep in January 2010. Some concerns raised were:

  • It's just one particular example of the general scaling / sizing problems in Sugar. See #39, #871 and an explanation (on sugar-devel) of relationship between number of pixels, physical screen size, viewer distance and angular size (the one perceived by the viewer).
  • A well-chosen default font is likely to have a better effect overall.
  • Saving the last-chosen font globally means you can break the entire Write activity, rather than just a single instance. You can't just start over or resume a previous version.

Sugar doesn't have a concept of global configuration for an activity yet (though there is a suitable place for storing activity-global data), at least partly because of the above concern (regarding breaking all instances rather than just a single one). Please ask the Design Team for input if you still plan on implementing this.

comment:9 Changed 8 years ago by godiard

  • Owner changed from tomeu to godiard
  • Status changed from new to assigned

Changed 8 years ago by lionaneesh

Patch for sugar-0.94, Note: This is a GCI task (http://www.google-melange.com/gci/task/view/google/gci2012/7950210)

comment:10 Changed 8 years ago by godiard

  • Keywords AU1B added

comment:11 Changed 8 years ago by DeepakMuddha

  • Resolution set to fixed
  • Status changed from assigned to closed

Issue resolved with Write activity v93

comment:12 Changed 8 years ago by godiard

To configure use:

gconftool-2 -s --type string /desktop/sugar/activities/write/font_face Sans
gconftool-2 -s --type int /desktop/sugar/activities/write/font_size 20

Note: See TracTickets for help on using tickets.