Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1685 closed defect (fixed)

Problem with Spanish translation of "random"

Reported by: kevin.benavides Owned by: walter
Priority: High Milestone:
Component: Turtleart Version: Unspecified
Severity: Blocker Keywords:
Cc: dsd Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

In version 81 of TurtleArt, the "Random" block in the block selection area says "direccion" which is an incorrect translation.

When you drag out this "direccion" block, it mysteriously changes to "rumbo" which is the correct translation of the word.

Change History (9)

comment:1 Changed 11 years ago by walter

  • Resolution set to incomplete
  • Status changed from new to closed

Hmm. There seems to be an inconsistency here. I see "aleatorio" in both the selector and the block itself. This matches the current version of the PO file in git (http://git.sugarlabs.org/projects/turtleart/repos/mainline/blobs/master/po/es.po line 794). I don't recall when the string was changed from rumbo in Pootle, but git says the last modification was Sept. 23.

Line 513 (http://git.sugarlabs.org/projects/turtleart/repos/mainline/blobs/master/images/es/numbers/numbersgroup.svg) also has the string "aleatorio".

I'll double-check the .xo bundle itself, but until we get confirmation one way or another from the translation team, I am not sure what action I should take.

comment:2 Changed 11 years ago by RafaelOrtiz

The right term is aleatorio. so rumbo should be discarded.

comment:3 Changed 11 years ago by dsd

OK.

And do we have an explanation for why the block in the blocks view has a different word from the block that appears when you drag it out onto the canvas?

comment:4 Changed 11 years ago by walter

No idea where "direccion" is coming from...It is not in the artwork in the 81 bundle, as far as I can tell.

comment:5 Changed 11 years ago by dsd

Ah, I didn't realise the blocks view is a static image. See ./images/es/turtle/turtlegroup.svg from the TurtleArt-81 xo bundle. It's the lower-most block.

comment:6 Changed 11 years ago by walter

  • Resolution incomplete deleted
  • Status changed from closed to reopened

The Random block is not in the Turtle Group. It is in the Number Group.
Ah. I now see what you are talking about. Rumbo or Direccion for the heading brick. When you said Random in your initial post, you through me off. I do see the problem and will correct it.

comment:7 Changed 11 years ago by walter

throughthrew

comment:8 Changed 11 years ago by dsd

oh, ok. I thought that was supposed to be random. That explains its non-random behaviour.

I was about to write that I can't see a random block in the numbers view, but now I see it. The text is unreadable, I only saw it because I was looking for a block with that exact word. Can it be enlarged?

comment:9 Changed 11 years ago by walter

  • Resolution set to fixed
  • Status changed from reopened to closed

I fixed the mistranslated block (rumbo-dirrecion) and increased the font size on the random block on the palette in v82.

Sorry it took so long. I am in the process of refactoring all of TA so hopefully this is the last patch to the old codebase :)

-walter

Note: See TracTickets for help on using tickets.