Opened 9 years ago

Closed 9 years ago

#1633 closed defect (notabug)

Numeric and text input fails on Turtle Art v81 under Debian 5.0

Reported by: roberto Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Debian
Bug Status: Unconfirmed

Description

i launch sugar, then TA and then i plug-in a forward block which
comes with a number block with a 100 value by default;
then i click on the number block and try to modify the number but
nothing happens; the number is fixed there;
identical problem when i try to input text

by-the-way, the code runs perfectly, even when i use other sample codes provided in the xo bundle

this is a link to the thread started in iaep list
http://lists.sugarlabs.org/archive/iaep/2009-December/009645.html

Attachments (5)

org.laptop.TurtleArtActivity-4.log (7.5 KB) - added by roberto 9 years ago.
TA log using tawindow.py provided
tawindow.py (30.9 KB) - added by walter 9 years ago.
new version of tawindow.py (2010-01-07)
org.laptop.TurtleArtActivity-1.log (864 bytes) - added by roberto 9 years ago.
log for TA not starting (with blinking turtle)
org.laptop.TurtleArtActivity-1.2.log (864 bytes) - added by roberto 9 years ago.
log with last version of tawindow .py
TurtleArt-82.xo (3.2 MB) - added by walter 9 years ago.

Change History (25)

comment:1 Changed 9 years ago by walter

  • Status changed from new to accepted

comment:2 Changed 9 years ago by tonyforster

tonyforster added to notification list

comment:3 Changed 9 years ago by roberto

some more data, following suggestions previously received by email:

When you click the number block does it get a blue border?

no

get a name block from the variable block tab
can you enter text and digits?

no

does it get a black border when clicked?

no

Does the backspace key do anything?

no

get show text blocks from the turtle tab
does it get a black border?

no

does backspace work?

the backspace and all the keyboard keys work fine when i type letters outside those block, e.g. in the upper left search dialog box

From the redbox tab get query kb and keyboard
run the program: forever query kb print keyboard
does it work?

the yellow stripe appears but whichever key i press, i can see only a "0"

Try the text boxes on the action and box blocks on the variable block tab?

sorry, i can't understand this question

comment:4 follow-up: Changed 9 years ago by walter

I've attached a version of tawindow.py (please use it as a replacement for the one that was in the .xo bundle by copying it into ~/Activities/TurtleArt.activity/) which has additional debugging output.

Please run Turtle Art, try clicking on the number block, see if the blue highlight appears, type some text, etc. and then attach the log file to this ticket.

thanks.

Changed 9 years ago by roberto

TA log using tawindow.py provided

comment:5 in reply to: ↑ 4 Changed 9 years ago by roberto

Replying to walter:

Please run Turtle Art, try clicking on the number block, see if the blue highlight appears, type some > text, etc. and then attach the log file to this ticket.

done, the attachment is there

thank you

comment:6 follow-up: Changed 9 years ago by walter

Roberto,

Thanks. The log is helpful (there seems to be a Sugar error showing up that is independent of any Turtle Art problem).

Questions: It appears from the log that you were clicking on a stack that asked for keyboard input. The keyboard input appears to have been captured. Was it appearing in your print statements?

Did you also try clicking on the number or text blocks? If so, there is no evidence in the logs, so I will have to dig deeper in my debugging.

thanks. (and Happy New Year).

-walter

comment:7 in reply to: ↑ 6 Changed 9 years ago by roberto

Replying to walter:

Questions: It appears from the log that you were clicking on a stack that asked for keyboard input. > The keyboard input appears to have been captured. Was it appearing in your print statements?

unfortunately nothing was displayed in the yellow bar

Did you also try clicking on the number or text blocks? If so, there is no evidence in the logs, so I will have to dig deeper in my debugging.

yes, i clicked many times both on the number and on the text blocks but neither the first nor the second were surrounded by the blue line

thanks. (and Happy New Year).

you're welcome,
i'll try again in the week-end, more free time to sugarize

comment:8 follow-up: Changed 9 years ago by walter

I've attached a version of tawindow.py with even more debug output. Also I created a short video (http://www.dailymotion.com/video/xbs2jx_debug-ta_tech) to show what it should look like. Please report back after you weekend tests.

Changed 9 years ago by walter

new version of tawindow.py (2010-01-07)

comment:9 in reply to: ↑ 8 Changed 9 years ago by roberto

Replying to walter:

I've attached a version of tawindow.py with even more debug output. Also I created a short video >(http://www.dailymotion.com/video/xbs2jx_debug-ta_tech) to show what it should look like. Please >report back after you weekend tests.

thank you for the video, very explanatory;

now, i pasted the last version of tawindow.py and unfortunately, something went wrong with TA this time since when i click on the turtle, it starts blinking indefinitely and nothing happens; the activity does not begin at all; only the turtle blinks on and off

on the other hand, i tried opening TA with the next-to-last tawindow.py you gave me (just to make a check on my sugar) and TA starts but, of course, the problem about numeric and textual input is still there

if you need more output or information, tell me

comment:10 follow-up: Changed 9 years ago by walter

If you could please attach the log file from a session where TA fails to start, that would help me track down the problem with the latest. It may be relevant as the patch works in my set up. Thanks.

comment:11 in reply to: ↑ 10 Changed 9 years ago by roberto

Replying to walter:

If you could please attach the log file from a session where TA fails to start, that would help me >track down the problem with the latest. It may be relevant as the patch works in my set up. Thanks.

do you mean a specific log for TA (such as the one i posted in a previous message) or a general log for the sugar-emulator session ? in this case, can you give me the exact path to it ?

thanks

comment:12 Changed 9 years ago by walter

I mean a log similar to the ones you posted previously for Turtle Art. When an activity fails to launch (the indefinite blinking icon) often there is a relevant error message in the log file for that activity.

Changed 9 years ago by roberto

log for TA not starting (with blinking turtle)

comment:13 Changed 9 years ago by roberto

i've just attached the log

comment:14 follow-up: Changed 9 years ago by walter

From the log, it appears that something must have gone wrong in the process of downloading tawindow.py and putting it into ~/Activities/TurtleArt.activity

Otherwise, I am at a loss. Please try downloading the patch again. If it still fails to launch, I will create a new bundle for you to try.

Changed 9 years ago by roberto

log with last version of tawindow .py

comment:15 in reply to: ↑ 14 Changed 9 years ago by roberto

Replying to walter:

From the log, it appears that something must have gone wrong in the process of downloading >tawindow.py and putting it into ~/Activities/TurtleArt.activity

Otherwise, I am at a loss. Please try downloading the patch again. If it still fails to launch, I will >create a new bundle for you to try.

the problem is still there: turtle blinking and TA not starting

  1. may be a problem of file permissions ?
  2. may be a problem of python version ?

comment:16 follow-up: Changed 9 years ago by walter

I'll create a new bundle with verbose debugging output for you to install that will hopefully launch properly. Thanks for hanging in there.

comment:17 in reply to: ↑ 16 Changed 9 years ago by roberto

Replying to walter:

I'll create a new bundle with verbose debugging output for you to install that will hopefully launch >properly. Thanks for hanging in there.

thank you,
i'll use the new file as soon as it's ready

comment:18 follow-up: Changed 9 years ago by walter

Test procedure:

First, install the attached xo bundle (I bumped the version number, so it should overwrite any version you already have installed.)

Second, launch Turtle Art.

If it doesn't launch, try running it from outside of Sugar from a terminal:
cd ~/Activities/TurtleArt.activity
./turtleart.py

Third, run these commands.

  1. create a Forward block
  2. click on the purple Number block
  3. type 123
  4. create a Left block
  5. snap it to the forward block by dragging it just below it
  6. click on the purple Number block
  7. type 99
  8. click on the Flow tab to select a Repeat block
  9. drag the Forward-Left group onto the Repeat block
  10. click on the purple Number block
  11. type 5
  12. click on the Repeat block -- the turtle should draw

Fourth: Quit Turtle Art and look at the log:

./turtleart.py
processing button press on category
creating new block forward
processing forward block in button release
block operation is move
block operation: move
processing button press on block
block_pressed (number)
disconnecing number from forward
processing number block in button release
block operation is click
connecting number to forward
block operation: click
block operation is click
number block selected
setting selection mask
processing key press: 1
processing keyboard input for number block
processing key press: 2
processing keyboard input for number block
processing key press: 3
processing keyboard input for number block
unselecting number
processing button press on canvas
processing button press on category
creating new block left
processing left block in button release
block operation is move
connecting left to forward
block operation: move
processing button press on block
block_pressed (number)
disconnecing number from left
processing number block in button release
block operation is click
connecting number to left
block operation: click
block operation is click
number block selected
setting selection mask
processing key press: 9
processing keyboard input for number block
processing key press: 9
processing keyboard input for number block
unselecting number
processing button press on canvas
processing button press on selbutton
processing button press on category
creating new block repeat
processing repeat block in button release
block operation is move
connecting repeat to forward
block operation: move
processing button press on block
block_pressed (number)
disconnecing number from repeat
processing number block in button release
block operation is click
connecting number to repeat
block operation: click
block operation is click
number block selected
setting selection mask
processing key press: 5
processing keyboard input for number block
unselecting number
processing button press on canvas
processing button press on block
block_pressed (repeat)
processing repeat block in button release
block operation is click
block operation: click
block operation is click
['repeat', 5.0, '[', 'forward', 123.0, 'left', 99.0, ']']

Changed 9 years ago by walter

comment:19 in reply to: ↑ 18 Changed 9 years ago by roberto

Replying to walter:

Test procedure:

First, install the attached xo bundle (I bumped the version number, so it should overwrite any >version you already have installed.)

ok

please find below the log i received running turtleart from command line;
before doing that, i tried running the last version you gave me, from within sugar:

  1. the turtle icon does not appear in the main activity view
  2. i started TA all the same via the journal entry of the last activity of some days ago
  3. the behavior was exactely the same as in my last posts
  4. finally, using turtleart.py outside sugar-emulator it seems everything works better; i mean the purple blocks get the blue line around when i click on them and i can successfully change the default number;

hence the problem seems to be in the emulator (?) not in TA

please consider that those commands like
"processing key press: Control_R"
are caused by switching between my multiple KDE desktops, since the

http://bugs.sugarlabs.org/ticket/1633

window was on another desktop

####################################################
./turtleart.py
processing button press on category
creating new block forward
processing forward block in button release
block operation is move
block operation: move
processing key press: Control_R
processing button press on block
block_pressed (number)
disconnecing number from forward
processing number block in button release
block operation is click
connecting number to forward
block operation: click
block operation is click
number block selected
setting selection mask
processing key press: 1
processing keyboard input for number block
processing key press: 2
processing keyboard input for number block
processing key press: 3
processing keyboard input for number block
processing key press: Control_R
processing keyboard input for number block
unselecting number
processing button press on category
creating new block left
processing left block in button release
block operation is move
block operation: move
processing key press: Control_R
processing button press on block
block_pressed (left)
processing left block in button release
block operation is move
connecting left to forward
block operation: move
processing button press on block
block_pressed (left)
disconnecing left from forward
processing left block in button release
block operation is move
connecting left to forward
block operation: move
processing button press on block
block_pressed (number)
disconnecing number from left
processing number block in button release
block operation is click
connecting number to left
block operation: click
block operation is click
number block selected
setting selection mask
processing key press: 9
processing keyboard input for number block
processing key press: 9
processing keyboard input for number block
unselecting number
processing button press on canvas
processing key press: Control_R
processing button press on selbutton
processing button press on category
creating new block repeat
processing repeat block in button release
block operation is move
block operation: move
processing button press on block
block_pressed (forward)
processing forward block in button release
block operation is move
connecting forward to repeat
block operation: move
processing button press on block
block_pressed (forward)
disconnecing forward from repeat
processing forward block in button release
block operation is move
connecting forward to repeat
block operation: move
processing button press on block
block_pressed (number)
disconnecing number from repeat
processing number block in button release
block operation is click
connecting number to repeat
block operation: click
block operation is click
number block selected
setting selection mask
processing key press: 5
processing keyboard input for number block
unselecting number
processing button press on canvas
processing key press: Control_R
processing button press on block
block_pressed (repeat)
processing repeat block in button release
block operation is move
block operation: move
processing button press on block
block_pressed (repeat)
processing repeat block in button release
block operation is click
block operation: click
block operation is click
['repeat', 5.0, '[', 'forward', 123.0, 'left', 99.0, ']']
#########################################################

comment:20 Changed 9 years ago by walter

  • Resolution set to notabug
  • Status changed from accepted to closed

Seems it is not a TA bug after all...

Note: See TracTickets for help on using tickets.