Opened 12 years ago

Closed 12 years ago

#144 closed defect (fixed)

My Icon: move the menu to the frame

Reported by: rkabir Owned by: rkabir
Priority: minor Milestone:
Component: Sugar Version: 0.83.x
Severity: Blocker Keywords: r+
Cc: Eben Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

It would be convenient to access the items from anywhere via the frame.

Attachments (2)

xomenu_patch (3.7 KB) - added by rkabir 12 years ago.
patch to create xomenu.py, deviceicon
xomenu_patch_take2 (3.3 KB) - added by rkabir 12 years ago.
reviewed patch, incorporating tomeu's feedback

Download all attachments as: .zip

Change History (10)

Changed 12 years ago by rkabir

patch to create xomenu.py, deviceicon

comment:1 Changed 12 years ago by rkabir

  • Keywords r? added

|TestCase|
Invoke the frame, verify that an XO icon appears.
Hover on the icon, and verify that the Restart, Shutdown, and Settings items appear.
Ensure each item works as expected.

comment:2 follow-up: Changed 12 years ago by erikos

  • Cc Eben added

Rkabir, thanks for submitting the patch!

Before I review the technical details - Eben can you comment on the design part?

I guess to be able to access the menu from all the home screen you could make the palette as well accessible from the mesh and groups view. That would not work for the activity view, though.

comment:3 Changed 12 years ago by tomeu

+        self._model = SystemModel()

If SystemModel doesn't contain anything relevant, is better to take it out completely. Also, we are trying to keep at a minimum the GObject-based classes because of memory usage.

We are not following MVC strictly at all, just found it to be a nice way to divide responsibilities in some parts of the shell.

+        self.set_size_request(style.zoom(style.GRID_CELL_SIZE * 2), -1)

Do we really need to set a fixed size? set_size_request can cause layout issues in other resolutions.

+    def __popup_cb(self, palette_):
+        pass

Better to take this out if it's not needed.

The patch looks great, will push a reviewed version as I think to remember that Eben agreed on this during the SugarCamp.

Thanks!

comment:4 in reply to: ↑ 2 Changed 12 years ago by tomeu

Replying to erikos:

Rkabir, thanks for submitting the patch!

Before I review the technical details - Eben can you comment on the design part?

I guess to be able to access the menu from all the home screen you could make the palette as well accessible from the mesh and groups view. That would not work for the activity view, though.

The palette is attached to a device icon in the frame, so will be accessible from everywhere where the frame is.

Changed 12 years ago by rkabir

reviewed patch, incorporating tomeu's feedback

comment:5 Changed 12 years ago by tomeu

  • Keywords r+ added; r? removed

comment:6 Changed 12 years ago by tomeu

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 follow-up: Changed 12 years ago by garycmartin

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Type changed from enhancement to defect
  • Version set to 0.83.x

Testing an XO running joyride 2631, the new palette for your XO frame buddy icon does not include the 'Register' option; not sure if this is intended or not. 'My Settings', 'Logout', 'Restart', 'Shutdown' all worked fine (though I'm not sure if 'Logout' should be showing on XO builds).

comment:8 in reply to: ↑ 7 Changed 12 years ago by tomeu

  • Bug Status set to Unconfimed
  • Distribution/OS set to Unspecified
  • Resolution set to fixed
  • Severity set to Blocker
  • Status changed from reopened to closed

Replying to garycmartin:

Testing an XO running joyride 2631, the new palette for your XO frame buddy icon does not include the 'Register' option; not sure if this is intended or not. 'My Settings', 'Logout', 'Restart', 'Shutdown' all worked fine (though I'm not sure if 'Logout' should be showing on XO builds).

Eben has been working on the XO menus recently and AFAIK that job is finished. Please check a recent build and reopen this if the same issue is still present.

Note: See TracTickets for help on using tickets.