Opened 12 years ago

Closed 12 years ago

#1321 closed defect (fixed)

file picker broken in Browse

Reported by: walter Owned by: marcopg
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: hulahop Version: Git as of bugdate
Severity: Unspecified Keywords: Browse
Cc: Distribution/OS: Ubuntu
Bug Status: Unconfirmed

Description

Running Browse 112 with a newly built hulahop from sugar-jhbuild, the file picker failed to open:

DEBUG:xpcom:Python Factory creating FilePicker
1252681426.016407 DEBUG xpcom: Python Factory creating FilePicker
ERROR:xpcom:Unhandled exception calling 'int8 init(in nsISomething, in unicode &, in int16);'
Traceback (most recent call last):

File "/usr/lib/xulrunner-1.9.0.14/python/xpcom/server/policy.py", line 277, in _CallMethod_

return 0, func(*params)

File "/home/walter/sugar-jhbuild/install/share/sugar/activities/Browse.activity/filepicker.py", line 63, in init

self._parent = hulahop.get_view_for_window(parent).get_toplevel()

AttributeError: 'NoneType' object has no attribute 'get_toplevel'
1252681426.019871 ERROR xpcom: Unhandled exception calling 'int8 init(in nsISomething, in unicode &, in int16);'

Change History (3)

comment:1 Changed 12 years ago by walter

Apparently this is related to (dup of #782). The URL that failed for me is:

http://www.dailymotion.com/onestep

I did manage to get the file picker to work in the Attach file dialog within Trac.

Tomeu mentioned in IRC that he suspects the upload buttons inside of HTML frames.

comment:2 Changed 12 years ago by tomeu

Can you check if after updating hulahop this starts working? Have just checked in a fix for #782. If it is fixed now, please close this one as obsolete.

comment:3 Changed 12 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

The filepicker now appears for the Dailymotion site!! I'll let you know if I discover any other sites that seems to be a problem, but let's consider this one closed. Thanks.

Note: See TracTickets for help on using tickets.