Opened 11 years ago

Closed 11 years ago

#782 closed defect (fixed)

Can't download a pdf from gmail

Reported by: CarolineM Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Browse Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

When I try to download an attachment pdf it never stops saying "downloading" in my journal

SoaS- Beta-1

Change History (4)

comment:1 Changed 11 years ago by CarolineM

This bug is still there.

comment:2 Changed 11 years ago by erikos

I had to use the follow link option (in the palette when you right click on the item). Tomeu knows more about the back story.

comment:3 Changed 11 years ago by tomeu

DEBUG:xpcom:Python Factory creating HelperAppLauncherDialog
1251806117.139867 DEBUG xpcom: Python Factory creating HelperAppLauncherDialog
DEBUG:xpcom:Python Factory creating Download
1251806117.160333 DEBUG xpcom: Python Factory creating Download
1251806117.186380 DEBUG root: Download.init dom_window: <XPCOM component '<unknown>' (implementing nsIDOMAbstractView,nsIDOMEventTarget,nsIDOMJSWindow,nsIDOMStorageWindow,nsIDOMStorageWindow_1_9_1,nsIDOMViewCSS,nsIDOMWindow,nsIDOMWindowInternal)>
ERROR:xpcom:Unhandled exception calling 'int8 init(in nsISomething, in nsISomething, in unicode &, in nsISomething, in uint64, in nsISomething, in nsISomething);'
Traceback (most recent call last):
  File "/home/tomeu/sugar-jhbuild/install/lib/xulrunner-1.9.1.3pre/python/xpcom/server/policy.py", line 277, in _CallMethod_
    return 0, func(*params)
  File "/home/tomeu/Activities/Browse.activity/downloadmanager.py", line 139, in init
    self._activity = view.get_toplevel()
AttributeError: 'NoneType' object has no attribute 'get_toplevel'
1251806117.188300 ERROR xpcom: Unhandled exception calling 'int8 init(in nsISomething, in nsISomething, in unicode &, in nsISomething, in uint64, in nsISomething, in nsISomething);'
Traceback (most recent call last):
  File "/home/tomeu/sugar-jhbuild/install/lib/xulrunner-1.9.1.3pre/python/xpcom/server/policy.py", line 277, in _CallMethod_
    return 0, func(*params)
  File "/home/tomeu/Activities/Browse.activity/downloadmanager.py", line 139, in init
    self._activity = view.get_toplevel()
AttributeError: 'NoneType' object has no attribute 'get_toplevel'
1251806117.241600 DEBUG root: datastore.write
1251806117.260617 DEBUG root: dbus_helpers.create: 36beedb4-5bcb-4e63-bbf1-04e8952314bb
1251806117.267303 DEBUG root: Written object 36beedb4-5bcb-4e63-bbf1-04e8952314bb to the datastore.
/home/tomeu/sugar-jhbuild/install/lib/python2.6/site-packages/sugar/graphics/alert.py:151: GtkWarning: Failed to set text from markup due to error parsing markup: Error on line 5 char 50: Odd character '@', expected a '>' or '/' character to end the start tag of element 'desireemarie7', or optionally an attribute; perhaps you used an invalid character in an attribute name
  self._msg_label.set_markup(self._msg)
ERROR:xpcom:Unhandled exception calling 'int8 onStateChange(in nsISomething, in nsISomething, in uint32, in uint32);'
Traceback (most recent call last):
  File "/home/tomeu/sugar-jhbuild/install/lib/xulrunner-1.9.1.3pre/python/xpcom/server/policy.py", line 277, in _CallMethod_
    return 0, func(*params)
  File "/home/tomeu/Activities/Browse.activity/downloadmanager.py", line 155, in onStateChange
    self._activity.add_alert(alert)
AttributeError: Download instance has no attribute '_activity'
1251806117.283459 ERROR xpcom: Unhandled exception calling 'int8 onStateChange(in nsISomething, in nsISomething, in uint32, in uint32);'
Traceback (most recent call last):
  File "/home/tomeu/sugar-jhbuild/install/lib/xulrunner-1.9.1.3pre/python/xpcom/server/policy.py", line 277, in _CallMethod_
    return 0, func(*params)
  File "/home/tomeu/Activities/Browse.activity/downloadmanager.py", line 155, in onStateChange
    self._activity.add_alert(alert)
AttributeError: Download instance has no attribute '_activity'

comment:4 Changed 11 years ago by tomeu

  • Resolution set to fixed
  • Status changed from new to closed

|TestCase|

  1. Open GMail in Browse
  2. Open an email that contains a PDF attachment
  3. Click on the Download button
  4. Check that a message appears saying that the download started
  5. Check the download finishes and the PDF is correctly saved in the Journal

Fixed by http://git.sugarlabs.org/projects/hulahop/repos/mainline/commits/115c002a

Note: See TracTickets for help on using tickets.