Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#1311 closed defect (fixed)

alt key gets stuck in favorites view

Reported by: tomeu Owned by: alsroot
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: r+
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Once you release it, the favorites view should go back to resume mode.

Attachments (1)

sugar-1311.patch (1.3 KB) - added by alsroot 10 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by tomeu

|TestCase|

  • switch to favorites view, make sure there's some entries in the journal
  • hold Alt key pressed, check that icons get uncolored
  • release Alt key, check that icons get colored again

comment:2 Changed 10 years ago by tomeu

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 10 years ago by alsroot

  • Keywords r? added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Changed 10 years ago by alsroot

comment:4 Changed 10 years ago by alsroot

Do not reseting resume mode on every visibility change, otherwise it hides palette on its openning(since it causes visibility notify event).

comment:5 Changed 10 years ago by alsroot

  • Milestone changed from Unspecified by Release Team to 0.86

comment:6 Changed 10 years ago by tomeu

  • Keywords r+ added; r? removed
  • Owner changed from tomeu to alsroot
  • Status changed from reopened to assigned

comment:7 Changed 10 years ago by alsroot

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:8 follow-up: Changed 10 years ago by garycmartin

FWIW, holding Alt down in my F11 sugar-jhbuild environment seems to behave like an auto key repeat, it is as if the entire set of icons are being continually re-generated/drawn rather than just on key down, key up. CPU load goes through the roof, and if I hold Alt for 3-4 sec or more the machine is locked up for 7-8 seconds.

comment:9 in reply to: ↑ 8 Changed 10 years ago by tomeu

Replying to garycmartin:

FWIW, holding Alt down in my F11 sugar-jhbuild environment seems to behave like an auto key repeat, it is as if the entire set of icons are being continually re-generated/drawn rather than just on key down, key up. CPU load goes through the roof, and if I hold Alt for 3-4 sec or more the machine is locked up for 7-8 seconds.

Thanks, opened #1316 about this one.

comment:10 Changed 6 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.