Opened 11 years ago

Closed 8 years ago

Last modified 7 years ago

#1316 closed defect (fixed)

holding Alt key for some time while in the home view locks up machine temporarily

Reported by: tomeu Owned by: tomeu
Priority: High Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: garycmartin, alsroot Distribution/OS: Unspecified
Bug Status: New

Description (last modified by tomeu)

from #1311:

FWIW, holding Alt down in my F11 sugar-jhbuild environment seems to behave like an auto key repeat, it is as if the entire set of icons are being continually re-generated/drawn rather than just on key down, key up. CPU load goes through the roof, and if I hold Alt for 3-4 sec or more the machine is locked up for 7-8 seconds.

Change History (11)

comment:1 Changed 11 years ago by tomeu

  • Description modified (diff)

comment:2 follow-up: Changed 11 years ago by tomeu

  • Cc garycmartin added

Hmm, cannot reproduce it. Anything special in your keyboard configuration? If you run xev, does it autorepeat for Alt? Here it autorepeats for other keys, but not for Alt.

comment:3 in reply to: ↑ 2 Changed 11 years ago by garycmartin

Replying to tomeu:

Hmm, cannot reproduce it. Anything special in your keyboard configuration? If you run xev, does it autorepeat for Alt? Here it autorepeats for other keys, but not for Alt.

Nothing special, but I am in a VirtualBox VM. Running xev shows modifiers are autorepeating (Alt, Ctrl, Shift).

comment:4 follow-up: Changed 11 years ago by alsroot

  • Bug Status changed from Unconfirmed to Needinfo

For me it looks like non-sugar issue to check it:
|TestCase|

  • create in VM another user(to not use gconf options)
  • start X session for this user
  • run xev
  • does it repeat modifiers keys presing?

comment:5 Changed 11 years ago by alsroot

  • Cc alsroot added

comment:6 Changed 11 years ago by alsroot

  • Milestone changed from Unspecified by Release Team to 0.86

comment:7 Changed 11 years ago by alsroot

  • Priority changed from Unspecified by Maintainer to High

comment:8 in reply to: ↑ 4 Changed 11 years ago by garycmartin

  • Bug Status changed from Needinfo to New
  • Version changed from Unspecified to Git as of bugdate

Replying to alsroot:

For me it looks like non-sugar issue to check it:
|TestCase|

  • create in VM another user(to not use gconf options)
  • start X session for this user
  • run xev
  • does it repeat modifiers keys presing?

Sorry, identical behaviour, Alt, Ctrl, Shift all send a continuous stream of events. I can also eliminate the VM / my Mac HW setup from this. If I run xev from the VM F11 terminal the keys do not auto-repeat (just a key down and key up event). If I run xev from inside sugar-jhbuild, the Alt, Ctrl, Shift all send a continuous stream of events.

comment:9 Changed 11 years ago by garycmartin

FWIW: Just retesting. The Alt behaviour has improved, but it still seems to auto-repeat and pegs the CPU at 100% load if you hold the key down. However, the improvement is that when you release Alt after holding down for a second or so, it immediately redraws the icons back to their resume colour state, and the CPU load immediately drops back to normal (previously it seemed to continue to process a full buffer of key down events and so locked up for a while).

comment:10 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

comment:11 Changed 7 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.