Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#1237 closed defect (notabug)

The language selector lists the available system locales instead of the sugar provided translations

Reported by: quidam Owned by: sayamindu
Priority: High Milestone:
Component: Sugar Version: 0.84.x
Severity: Major Keywords:
Cc: alsroot Distribution/OS: Unspecified
Bug Status: Assigned

Description

The list of available languages should not be taken from the system locales (listed with locale -a), but from the list of translations the Sugar core provides (e.g. dpkg -L sugar|grep MESSAGES$).

Even if the only system locale is C, all languages should work in Sugar if the LANG and/or LANGUAGE vars are set properly, something that can be managed by gdm. If the user can choose the language this way, the system doesn't need to provide all the locales, saving space and compilation time -installing all the locales in a slow laptop is a pain in the ass-.

As an example, the Sugar live cd I'm working on -using Trisquel GNU/Linux Edu-, does only include the English locale, but allows you to select other languages at boot time. Sugar runs properly in that language, but does not list the available Sugar languages if you start the system in other language than English -in fact, the language selection dialog fails to open-. If you choose English, then you can't select all the languages provided by sugar either, just English, Dari, Kreyol and Pashto (maybe a parsing error?)

If someone wants to test the iso I've made, it can be downloaded from http://devel.trisquel.info/trisquel-sugar_2.2ALPHA_i686.iso

Change History (8)

comment:1 Changed 12 years ago by alsroot

  • Cc alsroot added

comment:2 Changed 12 years ago by tomeu

  • Owner changed from tomeu to sayamindu
  • Status changed from new to assigned

comment:3 Changed 12 years ago by tomeu

  • Type changed from enhancement to defect

Isn't this a bug?

comment:4 Changed 12 years ago by quidam

It might be called a bug, I don't know if that is the intended behaviour. Anyway, I think that it should work in one of this two ways:

-Include a language selector window, and allow you to choose from any language provided by Sugar,
-Remove the selector, and use the lang variables set by gdm. This will need all the wanted languages to be installed as system locales.

The first one is better, as sugar will already use the gdm variable if available.

comment:5 Changed 12 years ago by sascha_silbe

I don't think Sugar will work properly without the system locales installed. Locales are about much more than just language (=translations), the most important ones (for Sugar) being decimal separators and date/time format.

comment:6 Changed 12 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Milestone changed from Unspecified by Release Team to 0.86
  • Priority changed from Unspecified by Maintainer to High
  • Severity changed from Unspecified to Major

Is there anything we can do about it in 0.86?

comment:7 Changed 12 years ago by sayamindu

  • Resolution set to notabug
  • Status changed from assigned to closed

Last time I checked, GDM queries the system locale list (same as what we do at present).
Unfortunately we cannot simply rely on translations being available to assume support for a language. While this will work for most European languages, languages like Arabic, etc, which need to be RTL will not work at all.
Locale information is a more important requirement for language support than translations.

Feel free to reopen if you think otherwise.

comment:8 Changed 8 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.