Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#1192 closed defect (fixed)

Object chooser remains shown after activity has been closed

Reported by: sascha_silbe Owned by: alsroot
Priority: Unspecified by Maintainer Milestone:
Component: Browse Version: Git as of bugdate
Severity: Unspecified Keywords: r+
Cc: Distribution/OS: Unspecified
Bug Status: New

Description

Steps to reproduce:

  1. Open Browse
  2. Navigate to some page that has a file upload form.
  3. Click "Browse" to open Journal object picker.
  4. Close the activity without closing the object picker first.

What I expected: Close the object picker as well.

What happened: The object picker is shown on top of the home view.

Attachments (1)

sugar-1192.patch (1.5 KB) - added by alsroot 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by alsroot

  • Component changed from sugar to Browse
  • Owner changed from tomeu to erikos

looks like its a Browse specific issue, in other activities it works fine if parent parameter was passed to ObjectChooser's ctor

comment:2 Changed 10 years ago by alsroot

  • Keywords r? added

comment:3 Changed 10 years ago by tomeu

  • Keywords r! added; r? removed

The problem with this is that several instances of the browse activity can run in the same process. That's why the parent var was in the instance and not in the class and why we have hulahop.get_view_for_window().

Changed 10 years ago by alsroot

comment:4 Changed 10 years ago by alsroot

  • Keywords r? added; r! removed

comment:5 Changed 10 years ago by tomeu

  • Keywords r+ added; r? removed
  • Owner changed from erikos to alsroot
  • Status changed from new to assigned

Looks great, thanks!

comment:6 Changed 10 years ago by erikos

  • Resolution set to fixed
  • Status changed from assigned to closed

Pushed, thanks for the patch.

commit 51863250cdea13209a8f2a75eacb8c54227a4465

comment:7 Changed 6 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.