Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#1186 closed defect (fixed)

turtle art variables are not being saved

Reported by: dgd Owned by: walter
Priority: Unspecified by Maintainer Milestone:
Component: Turtleart Version: Git as of bugdate
Severity: Major Keywords:
Cc: Distribution/OS: Ubuntu
Bug Status: Unconfirmed

Description

I have videos of the before and after on Youtube FWIW. Suffice to say that TA did not save variables on closing TA though I had renamed the activity with a new name.

Code blocks remained but the values in the code blocks reverted to default.

Marking as major because of the journaling aspect of Sugar should catch all changes in an activity before closing.

log for last TA session
1250360563.548576 DEBUG root: datastore.get
1250360563.555351 DEBUG root: dbus_helpers.get_properties: 22f64e5d-1ee3-48f5-82da-59f0aca0efa8
1250360563.678261 DEBUG sugar.presence.activity: <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>: Blocking on GetProperties() because someone wants property id
1250360563.697602 DEBUG sugar.presence.activity: <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>: initial GetProperties returned
1250360563.700029 DEBUG sugar.presence.activity: <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>: Activity properties changed to dbus.Dictionary({dbus.UTF8String('name'): dbus.UTF8String('Turtle Art Activity', variant_level=1), dbus.UTF8String('tags'): dbus.UTF8String(, variant_level=1), dbus.UTF8String('color'): dbus.UTF8String('#9A5200,#FF8F00', variant_level=1), dbus.UTF8String('private'): dbus.Boolean(False, variant_level=1), dbus.UTF8String('type'): dbus.UTF8String('org.laptop.TurtleArtActivity', variant_level=1), dbus.UTF8String('id'): dbus.UTF8String('2487135b2366aa21650f041f99809542ae72544b', variant_level=1)}, signature=dbus.Signature('sv'))
1250360563.704019 DEBUG sugar.presence.presenceservice: Created proxy <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>
1250360563.706602 DEBUG root: * Act 2487135b2366aa21650f041f99809542ae72544b, mesh instance <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>, scope public
1250360563.709310 DEBUG root:
* Act 2487135b2366aa21650f041f99809542ae72544b joining existing mesh instance <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>
1250360563.712755 DEBUG sugar.presence.activity: <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>: joining
1250360564.346424 DEBUG root: Palette.popdown immediate True
1250360564.363719 DEBUG root: Invoker set to <ToolInvoker object at 0x9ad470c (sugar+graphics+palettewindow+WidgetInvoker at 0x9c05e80)>
1250360564.376277 DEBUG root: ('Setup widget', <gtk.Button object at 0x9ad47d4 (GtkButton at 0x9a3c978)>)
1250360564.383029 DEBUG root: Palette.popdown immediate True
1250360564.401349 DEBUG root: Invoker set to <ToolInvoker object at 0x9ad4a2c (sugar+graphics+palettewindow+WidgetInvoker at 0x9c05e20)>
1250360564.404116 DEBUG root: ('Setup widget', <gtk.Button object at 0x9ad4a54 (GtkButton at 0x9a3c9f0)>)
1250360564.409331 WARNING root: No gtk.AccelGroup in the top level window.
1250360564.480782 DEBUG root: Invoker set to <ToolInvoker object at 0x9ad725c (sugar+graphics+palettewindow+WidgetInvoker at 0x9c0f6c0)>
1250360564.483634 DEBUG root: ('Setup widget', <gtk.Button object at 0x9ad7284 (GtkButton at 0x9a3ca68)>)
1250360564.487342 WARNING root: No gtk.AccelGroup in the top level window.
/home/denny/sugar-jhbuild/install/lib/python2.6/site-packages/sugar/graphics/window.py:272: DeprecationWarning: use toolbar_box instead of toolbox

warnings.warn('use toolbar_box instead of toolbox', DeprecationWarning)

/home/denny/sugar-jhbuild/install/lib/python2.6/site-packages/sugar/graphics/window.py:276: DeprecationWarning: use toolbar_box instead of toolbox

warnings.warn('use toolbar_box instead of toolbox', DeprecationWarning)

1250360564.675218 WARNING root: No gtk.AccelGroup in the top level window.
1250360564.789946 WARNING root: No gtk.AccelGroup in the top level window.
1250360564.809386 DEBUG root: Invoker set to <ToolInvoker object at 0x9ad7aa4 (sugar+graphics+palettewindow+WidgetInvoker at 0x9c18b20)>
1250360564.822935 DEBUG root: ('Setup widget', <gtk.Button object at 0x9ad7acc (GtkButton at 0x9a3cae0)>)
1250360564.827135 WARNING root: No gtk.AccelGroup in the top level window.
1250360564.839580 DEBUG root: Invoker set to <ToolInvoker object at 0x9adc284 (sugar+graphics+palettewindow+WidgetInvoker at 0x9c1ce50)>
1250360564.843013 DEBUG root: ('Setup widget', <gtk.Button object at 0x9adc234 (GtkButton at 0x9a3cb58)>)
1250360564.866927 WARNING root: No gtk.AccelGroup in the top level window.
1250360564.881117 DEBUG root: Invoker set to <ToolInvoker object at 0x9adc98c (sugar+graphics+palettewindow+WidgetInvoker at 0x9c1d1a0)>
1250360564.891403 DEBUG root: ('Setup widget', <gtk.Button object at 0x9adc964 (GtkButton at 0x9a3cc90)>)
1250360564.904239 WARNING root: No gtk.AccelGroup in the top level window.
1250360564.923602 DEBUG root: Invoker set to <ToolInvoker object at 0x9ade16c (sugar+graphics+palettewindow+WidgetInvoker at 0x9c21560)>
1250360564.926814 DEBUG root: ('Setup widget', <gtk.Button object at 0x9ade11c (GtkButton at 0x9a3cd08)>)
1250360564.957935 WARNING root: No gtk.AccelGroup in the top level window.
1250360564.968852 DEBUG root: Invoker set to <ToolInvoker object at 0x9ade89c (sugar+graphics+palettewindow+WidgetInvoker at 0x9c29a80)>
1250360564.981213 DEBUG root: ('Setup widget', <gtk.Button object at 0x9ade84c (GtkButton at 0x9a3cd80)>)
1250360564.986068 WARNING root: No gtk.AccelGroup in the top level window.
1250360565.019380 DEBUG root: Invoker set to <ToolInvoker object at 0x9adefcc (sugar+graphics+palettewindow+WidgetInvoker at 0x9c2a390)>
1250360565.023103 DEBUG root: ('Setup widget', <gtk.Button object at 0x9adef7c (GtkButton at 0x9a3cdf8)>)
1250360565.028457 WARNING root: No gtk.AccelGroup in the top level window.
1250360565.089023 DEBUG root: Invoker set to <ToolInvoker object at 0x9ae075c (sugar+graphics+palettewindow+WidgetInvoker at 0x9c2cd60)>
1250360565.215636 DEBUG root: ('Setup widget', <gtk.Button object at 0x9ae070c (GtkButton at 0x9a3cee8)>)
1250360565.222768 WARNING root: No gtk.AccelGroup in the top level window.
1250360565.237528 DEBUG root: Invoker set to <ToolInvoker object at 0x9ae0e8c (sugar+graphics+palettewindow+WidgetInvoker at 0x9c34210)>
1250360565.240328 DEBUG root: ('Setup widget', <gtk.Button object at 0x9ae0e3c (GtkButton at 0x9c31020)>)
1250360565.253086 WARNING root: No gtk.AccelGroup in the top level window.
1250360565.265756 DEBUG root: Invoker set to <ToolInvoker object at 0x9ae35cc (sugar+graphics+palettewindow+WidgetInvoker at 0x9c34170)>
1250360565.273655 DEBUG root: ('Setup widget', <gtk.Button object at 0x9ae361c (GtkButton at 0x9c31110)>)
/home/denny/sugar-jhbuild/install/lib/python2.6/site-packages/sugar/graphics/toolbutton.py:47: GtkWarning: gtk_accel_group_connect: assertion `accel_key > 0' failed

gtk.ACCEL_LOCKED | gtk.ACCEL_VISIBLE)

1250360565.362525 DEBUG root: Invoker set to <ToolInvoker object at 0x9ae3af4 (sugar+graphics+palettewindow+WidgetInvoker at 0x9c3bc70)>
1250360565.366805 DEBUG root: ('Setup widget', <gtk.Button object at 0x9ae35f4 (GtkButton at 0x9c31188)>)
1250360565.372356 WARNING root: No gtk.AccelGroup in the top level window.
1250360565.387029 DEBUG root: Invoker set to <ToolInvoker object at 0x9ae65f4 (sugar+graphics+palettewindow+WidgetInvoker at 0x9c3bf70)>
1250360565.390045 DEBUG root: ('Setup widget', <gtk.Button object at 0x9ae65cc (GtkButton at 0x9c31200)>)
1250360565.393368 WARNING root: No gtk.AccelGroup in the top level window.
1250360565.438237 DEBUG root: Invoker set to <ToolInvoker object at 0x9ae6aa4 (sugar+graphics+palettewindow+WidgetInvoker at 0x9c40d50)>
1250360565.453270 DEBUG root: ('Setup widget', <gtk.Button object at 0x9ae6cd4 (GtkButton at 0x9c31278)>)
1250360565.457986 WARNING root: No gtk.AccelGroup in the top level window.
1250360565.481661 DEBUG root: Invoker set to <ToolInvoker object at 0x9ae848c (sugar+graphics+palettewindow+WidgetInvoker at 0x9c4a900)>
1250360565.485235 DEBUG root: ('Setup widget', <gtk.Button object at 0x9ae8464 (GtkButton at 0x9c31368)>)
1250360565.538776 DEBUG root: Invoker set to <ToolInvoker object at 0x9ae8c34 (sugar+graphics+palettewindow+WidgetInvoker at 0x9c4d810)>
1250360565.564482 DEBUG root: ('Setup widget', <gtk.Button object at 0x9ae8c0c (GtkButton at 0x9c31400)>)
1250360565.594222 DEBUG root: Invoker set to <ToolInvoker object at 0x9aea3ec (sugar+graphics+palettewindow+WidgetInvoker at 0x9c522c0)>
1250360565.597015 DEBUG root: ('Setup widget', <gtk.Button object at 0x9aea3c4 (GtkButton at 0x9c314f0)>)
1250360567.471769 DEBUG root: Activity.canvas_map_cb
1250360567.558344 DEBUG root: dbus_helpers.get_filename: 22f64e5d-1ee3-48f5-82da-59f0aca0efa8, /home/denny/.sugar/default/data/22f64e5d-1ee3-48f5-82da-59f0aca0efa8.gtar
1250360567.567210 DEBUG turtleart-activity: Deferring reading file /home/denny/.sugar/default/data/22f64e5d-1ee3-48f5-82da-59f0aca0efa8.gtar
1250360569.743451 DEBUG turtleart-activity: Reading file /home/denny/.sugar/default/data/22f64e5d-1ee3-48f5-82da-59f0aca0efa8.gtar
1250360569.965745 DEBUG sugar.presence.presenceservice: Created proxy <Buddy object at 0x9afb43c (sugar+presence+buddy+Buddy at 0x9c7b3d0)>
1250360570.296587 DEBUG root: ActivityService.set_active: 1.
1250360570.900762 DEBUG sugar.presence.activity: <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>: new channel created at /org/freedesktop/Telepathy/Connection/gabble/jabber/_35c6dad5d8b11a10581f874bc4cb98d73cb50a9a6_40jabber_2esugarlabs_2eorg_2fTelepathy/MucChannel1
1250360570.905688 DEBUG sugar.presence.activity: <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>: new channel created at /org/freedesktop/Telepathy/Connection/gabble/jabber/_35c6dad5d8b11a10581f874bc4cb98d73cb50a9a6_40jabber_2esugarlabs_2eorg_2fTelepathy/MucTubesChannel1
(sugar-activity:4002): DEBUG: Got client ID "101b094b006c34d7db12503605719126000000035650002"
(sugar-activity:4002): DEBUG: Setting initial properties
(sugar-activity:4002): DEBUG: Received SaveYourself(SmSaveLocal, !Shutdown, SmInteractStyleNone, !Fast) in state idle
(sugar-activity:4002): DEBUG: Sending SaveYourselfDone(True) for initial SaveYourself
1250360572.109031 DEBUG sugar.presence.presenceservice: Reused proxy <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>
(sugar-activity:4002): DEBUG: Received SaveComplete message in state save-yourself-done
1250360572.114734 DEBUG sugar.presence.activity: <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>: buddy /org/laptop/Sugar/Presence/Buddies/keyid/5c6dad5d8b11a10581f874bc4cb98d73cb50a9a6 joined with handle 108
1250360572.130187 DEBUG sugar.presence.activity: <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>: Connection on org.freedesktop.Telepathy.Connection.gabble.jabber._35c6dad5d8b11a10581f874bc4cb98d73cb50a9a6_40jabber_2esugarlabs_2eorg_2fTelepathy at /org/freedesktop/Telepathy/Connection/gabble/jabber/_35c6dad5d8b11a10581f874bc4cb98d73cb50a9a6_40jabber_2esugarlabs_2eorg_2fTelepathy, channels: dbus.Array([dbus.Struct((dbus.ObjectPath('/org/freedesktop/Telepathy/Connection/gabble/jabber/_35c6dad5d8b11a10581f874bc4cb98d73cb50a9a6_40jabber_2esugarlabs_2eorg_2fTelepathy/MucChannel1'), dbus.String(u'org.freedesktop.Telepathy.Channel.Type.Text'), dbus.UInt32(2L), dbus.UInt32(1L)), signature=None), dbus.Struct((dbus.ObjectPath('/org/freedesktop/Telepathy/Connection/gabble/jabber/_35c6dad5d8b11a10581f874bc4cb98d73cb50a9a6_40jabber_2esugarlabs_2eorg_2fTelepathy/MucTubesChannel1'), dbus.String(u'org.freedesktop.Telepathy.Channel.Type.Tubes'), dbus.UInt32(2L), dbus.UInt32(1L)), signature=None)], signature=dbus.Signature('(osuu)'))
1250360572.194530 DEBUG sugar.presence.activity: <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>: Connection <telepathy.client.conn.Connection object at 0x9b0054c> is ready
1250360572.251411 DEBUG sugar.presence.activity: <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>: Text channel <telepathy.client.channel.Channel object at 0x9b0090c> is ready
1250360572.259426 DEBUG sugar.presence.activity: <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>: Tubes channel <telepathy.client.channel.Channel object at 0x9b009cc> is ready
1250360572.262241 DEBUG sugar.presence.activity: <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>: finished setting up tubes
1250360572.265463 DEBUG sugar.presence.activity: <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>: Join finished
1250360572.272094 DEBUG root: Palette.popdown immediate True
1250360572.279732 DEBUG turtleart-activity: I joined a shared activity.
1250360572.294509 DEBUG turtleart-activity: I am joining an activity: waiting for a tube...
1250360572.307805 DEBUG turtleart-activity: New tube: ID=1305430783 initator=110 type=0 service=org.laptop.TurtleArtActivity params=dbus.Dictionary({}, signature=dbus.Signature('sv')) state=0
/usr/lib/python2.6/site-packages/dbus/connection.py:242: DeprecationWarning: object.
init() takes no parameters

super(Connection, self).init(*args, kwargs)

1250360573.276089 DEBUG sugar.presence.presenceservice: Reused proxy <proxy for /org/laptop/Sugar/Presence/Activities/1 at 9a9198c>
1250360573.278775 DEBUG sugar.presence.presenceservice: Reused proxy <Buddy object at 0x9afb43c (sugar+presence+buddy+Buddy at 0x9c7b3d0)>
1250360573.309239 DEBUG turtleart-activity: receiving project from sharer
1250360662.417180 DEBUG sugar.presence.presenceservice: Created proxy <Buddy object at 0x9afbd4c (sugar+presence+buddy+Buddy at 0x9c7f380)>

Change History (7)

comment:1 Changed 12 years ago by walter

  • Component changed from sugar to Turtleart
  • Owner changed from tomeu to walter
  • Status changed from new to assigned

I'll investigate. DGD: can you post links to the videos?

comment:2 Changed 12 years ago by walter

  • Distribution/OS changed from Unspecified to Ubuntu

I cannot reproduce this. I don't see anything suspicious in the video that would have led to this behavior. Has it happened again?

comment:3 Changed 12 years ago by dgd

http://www.youtube.com/watch?v=jNYHp-Y1zJY

Yes. And keeps happening. You can see the undesired behavior in the video above.

comment:4 Changed 12 years ago by tomeu

  • Milestone changed from Unspecified by Release Team to 0.86

comment:5 Changed 12 years ago by walter

Dgd: any update? Still occurring? I have not been able to reproduce this one.

comment:6 Changed 12 years ago by dgd

  • Resolution set to fixed
  • Status changed from assigned to closed

Appears to be working in new jhbuilds.

comment:7 Changed 8 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.