Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1100 closed defect (fixed)

Calculate window size broken under Metacity

Reported by: garycmartin Owned by: garycmartin
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Calculate Version: Git as of bugdate
Severity: Critical Keywords:
Cc: sascha_silbe, sayamindu, tomeu Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Testing under Metacity (arrived Sugar 0.85.1) there are several Activities that's window layout breaks under it's window management (http://dev.sugarlabs.org/ticket/1044). For Calculate this is caused by a gtk.Table passing resize events up the inheritance chain to the window. With homogeneous set to True (current default), the window is offset and not fullscreen, but changes size as the cell content changes. With homogeneous set to False, the window correctly initially fills the screen, but grows as the cell content changes. Need to rework the layout and/or set some max/min.

Attachments (1)

Calculate on Metacity.png (85.1 KB) - added by garycmartin 12 years ago.

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by garycmartin

comment:1 Changed 12 years ago by garycmartin

  • Owner changed from rwh to garycmartin
  • Status changed from new to assigned

Will clone the Calculate git rep and submit fix with minimum alterations.

comment:2 Changed 12 years ago by sascha_silbe

  • Cc sascha_silbe added

Gary, please report back when you've cloned the repo so I can switch to it in sugar-jhbuild. Thanks!

comment:3 Changed 12 years ago by garycmartin

  • Cc sayamindu added

comment:4 Changed 12 years ago by garycmartin

  • Cc tomeu added
  • Resolution set to fixed
  • Status changed from assigned to closed

I've just been retesting after rebuilding with latest patches from today and yesterday, looks like it's fixed! Closing the ticket :-)

comment:5 Changed 12 years ago by sascha_silbe

Fixed in 929ce5a3cbf9.

Note: See TracTickets for help on using tickets.