Opened 12 years ago

Closed 12 years ago

#1101 closed defect (notsugar)

Disable checks while uploading .xo files

Reported by: alsroot Owned by: bernie
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: wiki.sugarlabs.org Version: Unspecified
Severity: Unspecified Keywords:
Cc: FGrose, sascha_silbe Distribution/OS: Unspecified
Bug Status: New

Description

I'm trying to upload http://people.sugarlabs.org/~alsroot/T.xo object bundle but wiki.sl.o claims for

This file contains HTML or script code that may be erroneously interpreted by a web browser.
Retrieved from "http://wiki.sugarlabs.org/go/Special:Upload"

I tried to disable "Ignore any warnings" checkbox but w/o any success

Change History (14)

comment:1 Changed 12 years ago by alsroot

  • Summary changed from Disable check for uploaded .xo files to Disable checks while uploading .xo files

comment:2 Changed 12 years ago by tomeu

  • Cc FGrose added

comment:3 Changed 12 years ago by dfarning

  • Owner changed from dfarning to bernie
  • Status changed from new to assigned

Changing owner to bernie. He is the man with access to the wiki internals.

comment:4 Changed 12 years ago by FGrose

  • Bug Status changed from Unconfirmed to New
  • Cc sascha_silbe added

comment:5 Changed 12 years ago by alsroot

So, it looks to .xo content?
Maybe we can disable these checks for .xo?

comment:6 follow-up: Changed 12 years ago by FGrose

A lot more .xo files have been uploaded to http://wiki.laptop.org/go/Special:Upload. Could you try uploading there as a test? Perhaps they have a solution.

comment:7 in reply to: ↑ 6 Changed 12 years ago by alsroot

Replying to FGrose:

A lot more .xo files have been uploaded to http://wiki.laptop.org/go/Special:Upload. Could you try uploading there as a test? Perhaps they have a solution.

the same result

This file contains HTML or script code that may be erroneously interpreted by a web browser.
Retrieved from "http://wiki.laptop.org/go/Special:Upload"

in fact, this .xo is a library packaged to object bundle,
I tried rename it to .xol but w/o any success

comment:8 follow-up: Changed 12 years ago by bernie

Works for me. I tried uploading this bundle and then deleted it:

http://wiki.sugarlabs.org/go/File:SocialCalcActivity-1.xo

Could you please try again?

comment:9 in reply to: ↑ 8 ; follow-up: Changed 12 years ago by alsroot

Replying to bernie:

Works for me. I tried uploading this bundle and then deleted it:

http://wiki.sugarlabs.org/go/File:SocialCalcActivity-1.xo

Could you please try again?

for http://people.sugarlabs.org/~alsroot/T.xo it doesn't work :(
I've tried Browse.xo and its ok

comment:10 in reply to: ↑ 9 ; follow-up: Changed 12 years ago by bernie

Replying to alsroot:

for http://people.sugarlabs.org/~alsroot/T.xo it doesn't work :(
I've tried Browse.xo and its ok

Are you trying to upload right from the URL? The URL you gave gives 403 because the file in your public_html is not world readable. Could this explain the problem?

comment:11 in reply to: ↑ 10 Changed 12 years ago by alsroot

Replying to bernie:

Replying to alsroot:

for http://people.sugarlabs.org/~alsroot/T.xo it doesn't work :(
I've tried Browse.xo and its ok

Are you trying to upload right from the URL? The URL you gave gives 403 because the file in your public_html is not world readable.

sorry, fixed(I uploaded it to let others reproduce bug)

Could this explain the problem?

I'm just trying to use
http://wiki.sugarlabs.org/go/Special:Upload
to upload T.xo(from local file)

comment:12 Changed 12 years ago by bernie

Ok I figured it out: it doesn't like a index.html file inside the xo bundle.

I still need to find out how to disable this paranoia in MediaWiki, but now you have a workaround.

comment:13 follow-up: Changed 12 years ago by bernie

I couldn't figure out why Mediawiki also scans inside the xo bundle and how to disable it.

If it's really a problem I can bang my head on the wall a little more.

comment:14 in reply to: ↑ 13 Changed 12 years ago by alsroot

  • Resolution set to notsugar
  • Status changed from assigned to closed

Replying to bernie:

I couldn't figure out why Mediawiki also scans inside the xo bundle and how to disable it.

If it's really a problem I can bang my head on the wall a little more.

well, at least we know about workaround

Note: See TracTickets for help on using tickets.