Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#1056 closed enhancement (fixed)

TA showing Journal object (image) should be centred and rotated

Reported by: garycmartin Owned by: walter
Priority: Unspecified by Maintainer Milestone:
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Tough to change just now you've started to use it in the field, but it seems like the brick for displaying a Journal object could be much more useful if it was centred on the turtle position, and rotated to match its orientation. That way you could use it to place arrays of images/shapes from Journal (like a bitmap brush). Loading in a PNG with alpha and trying to use it as a paint brush was the 2nd thing I tried (after displaying a dull screen shot) :-)

This could lead to some simple "sprite" like games/stories/animations – though some you could do now with the current ridged orientation (draw a couple of frames of a character in paint and use them to animate a walk in TA).

Change History (5)

comment:1 Changed 12 years ago by walter

  • Status changed from new to assigned

Nice idea. I don't think it will be an issue compatibility-wise. I don't think too many people have used the feature yet in any precise way. I was planning to slightly simplify the UI around the Show function in any case.

comment:2 Changed 12 years ago by garycmartin

  • Milestone changed from Unspecified by Release Team to 0.86

comment:3 Changed 12 years ago by walter

  • Status changed from assigned to accepted

Looks like arbitrary rotation will require a rebase to Cairo. Not sure if that is going to happen by Thursday. What I can definitely do is center the images under the turtle.

comment:4 Changed 12 years ago by walter

  • Resolution set to fixed
  • Status changed from accepted to closed

The current version in GIT centers media on the Turtle and centers text vertically on the Turtle. (I fixed a word wrap bug at the same time.)

Re rotation, I've opened a new ticket (#1203) re a Cairo rebase (it will fix some other problems as well) for 0.88.

comment:5 Changed 8 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.