Opened 12 years ago

Closed 9 years ago

#1055 closed defect (obsolete)

Memorize 33 crashes

Reported by: CarolineM Owned by: alsroot
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Memorize Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Needinfo

Description

Crashes or freezes if you pick speak during create.
Does not play a shared game with a Memorize 32 machine.
Seems slower.

Attachments (1)

tmp9lC0zR.txt (2.4 MB) - added by CarolineM 12 years ago.

Change History (21)

comment:1 Changed 12 years ago by erikos

  • Owner changed from erikos to alsroot
  • Status changed from new to assigned

comment:2 Changed 12 years ago by alsroot

  • Bug Status changed from Unconfirmed to Needinfo

Caroline, could you post org.laptop.Memorize* and shell.log
in debug mode(you need to uncomment "export SUGAR_LOGGER_LEVEL=debug" line in ~/.sugar/debug file)

comment:4 Changed 12 years ago by alsroot

also try this command in Terminal:
gst-launch-0.10 espeak text="1 2 3" ! alsasink

if doesn't speak ok "1 2 3", run it in debug mode:
gst-launch-0.10 espeak text="1" ! alsasink --gst-debug=5 > espeak.log 2>&1
and attach espeak.log which this commands should make

comment:5 Changed 12 years ago by CarolineM

  • (sugar-activity:2339): DEBUG: Got client ID "10e749410c644adfdb124814346846789300000021840000"

(sugar-activity:2339): DEBUG: Setting initial properties
(sugar-activity:2339): DEBUG: Received SaveYourself(SmSaveLocal, !Shutdown, SmInteractStyleNone, !Fast) in state idle
(sugar-activity:2339): DEBUG: Sending SaveYourselfDone(True) for initial SaveYourself
(sugar-activity:2339): DEBUG: Received SaveComplete message in state save-yourself-done
/usr/lib/python2.6/site-packages/sugar/util.py:25: DeprecationWarning: the sha module is deprecated; use the hashlib module instead

import sha

1248143540.723347 WARNING root: No gtk.AccelGroup in the top level window.
1248143540.748266 WARNING root: No gtk.AccelGroup in the top level window.
(sugar-activity:2370): DEBUG: Got client ID "10e749410c644adfdb124814354092453600000021840002"
(sugar-activity:2370): DEBUG: Setting initial properties
(sugar-activity:2370): DEBUG: Received SaveYourself(SmSaveLocal, !Shutdown, SmInteractStyleNone, !Fast) in state idle
(sugar-activity:2370): DEBUG: Sending SaveYourselfDone(True) for initial SaveYourself
(sugar-activity:2370): DEBUG: Received SaveComplete message in state save-yourself-done
1248143573.749065 WARNING root: No gtk.AccelGroup in the top level window.
1248143576.055788 WARNING root: No gtk.AccelGroup in the top level window.
1248143576.102102 WARNING root: No gtk.AccelGroup in the top level window.
1248143576.105160 WARNING root: No gtk.AccelGroup in the top level window.
Best voice for LANG en_US.UTF-8 seems to be en Default

comment:6 follow-up: Changed 12 years ago by CarolineM

how do I find the espeak log from Browse to attach it inside of Sugar?

[liveuser@localhost ~]$ gst-launch-0.10 espeak text="1 2 3" ! alsasink
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstAudioSinkClock
Got EOS from element "pipeline0".
Execution ended after 1760146962 ns.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...
[liveuser@localhost ~]$ gst-launch-0.10 espeak text="1" ! alsasink --gst-debug=5 > espeak.log 2>&1
[liveuser@localhost ~]$ ls
Activities espeak.log hosts mrfmvb
[liveuser@localhost ~]$ more espeak.log
0:00:00.003094891 2442 0x8793050 INFO GST_INIT gstquery.c:105:_gst_query_initial
ize: init queries
0:00:00.010272883 2442 0x8793050 DEBUG bin gstbin.c:476:gst_bin_class_init: cr
eating bin thread pool
0:00:00.016757751 2442 0x8793050 INFO GST_INIT gstmessage.c:73:_gst_message_init
ialize: init messages
0:00:00.021637235 2442 0x8793050 INFO GST_PLUGIN_LOADING gstplugin.c:261:_gst_plugin_initi
alize: registering 0 static plugins
0:00:00.021980979 2442 0x8793050 LOG GST_PLUGIN_LOADING gstplugin.c:243:gst_plugin_register_
static: attempting to load static plugin "staticelements" now...
0:00:00.022563422 2442 0x8793050 LOG GST_REFCOUNTING gstobject.c:265:gst_object_init:<
GstObject@0x87a8058> 0x87a8058 new
0:00:00.023115081 2442 0x8793050 LOG GST_PLUGIN_LOADING gstplugin.c:334:gst_plugin_register_
func: plugin "(NULL)" looks good
0:00:00.023581319 2442 0x8793050 LOG GST_REFCOUNTING gstobject.c:265:gst_object_init:<
GstObject@0x87a8800> 0x87a8800 new
0:00:00.023959761 2442 0x8793050 LOG GST_ELEMENT_FACTORY gstelementfactory.c:264:gst_eleme
nt_register:<bin> Created new elementfactory for type GstBi

comment:7 in reply to: ↑ 6 Changed 12 years ago by alsroot

Replying to CarolineM:

how do I find the espeak log from Browse to attach it inside of Sugar?

import it to Journal first:
"copy-to-journal espeak.log -m text/plain"

btw did "gst-launch-0.10 espeak text="1 2 3" ! alsasink" pronounce something?

Changed 12 years ago by CarolineM

comment:8 follow-up: Changed 12 years ago by CarolineM

no, speak doesn't seem to work on the stick anymore either.

comment:9 in reply to: ↑ 8 ; follow-up: Changed 12 years ago by alsroot

Replying to CarolineM:

no, speak doesn't seem to work on the stick anymore either.

could you try also:
"gst-launch-0.10 filesrc location=/usr/share/sounds/alsa/Front_Center.wav ! decodebin ! alsasink"
does it sound w/o artifacts?

comment:10 in reply to: ↑ 9 Changed 12 years ago by alsroot

Replying to alsroot:

Replying to CarolineM:

no, speak doesn't seem to work on the stick anymore either.

could you try also:
"gst-launch-0.10 filesrc location=/usr/share/sounds/alsa/Front_Center.wav ! decodebin ! alsasink"
does it sound w/o artifacts?

and
"gst-launch-0.10 filesrc location=/usr/share/sounds/alsa/Front_Center.wav ! decodebin ! pulsesink"
"gst-launch-0.10 espeak text="1 2 3" ! pulsesink"

unfortunately, pulse doesn't work well on my audio chipset(intel ICH8), so it all time sounds artifacts(in all cases not only with speak)

comment:11 follow-up: Changed 12 years ago by CarolineM

Hi,

This is still an issue and I don't really understand what information I should provide.

Given how poorly sound is working in general on SoaS right now maybe we should back off on trying to add speak to Memorize. Its an awesome feature but I think the underlying audio system is not up for it yet?

comment:12 in reply to: ↑ 11 Changed 12 years ago by garycmartin

Replying to CarolineM:

Given how poorly sound is working in general on SoaS right now maybe we should back off on trying to add speak to Memorize. Its an awesome feature but I think the underlying audio system is not up for it yet?

FWIW, I was just briefly testing Memorize and its speech feature on an XO-1 (http://dev.laptop.org/~smparrish/XO-1/builds/OS8). It was working very well, with no crashes, and smooth, clear speech playback.

comment:13 Changed 12 years ago by alsroot

Caroline, could you test last soas(in my case it sounds more smooth) and v34(was fixed bug which could potentially lead to crash).

comment:14 follow-up: Changed 12 years ago by CarolineM

I tested on a VirtualBox instance and version 34 still crashed.

Here is the log: http://screencast.com/t/RKvTXC1dJh

comment:15 in reply to: ↑ 14 Changed 12 years ago by alsroot

Replying to CarolineM:

I tested on a VirtualBox instance and version 34 still crashed.

Here is the log: http://screencast.com/t/RKvTXC1dJh

Did you start soas in VirtualBox? What exact iso version?
(I still can't reproduce this crash in all my envs)

comment:16 follow-up: Changed 12 years ago by CarolineM

I tried on both the GPA spin and June 24th Strawberry.

Here is the log
http://screencast.com/t/25XykN1O

Thanks!

comment:17 in reply to: ↑ 16 Changed 11 years ago by alsroot

Replying to CarolineM:

I tried on both the GPA spin and June 24th Strawberry.

Here is the log
http://screencast.com/t/25XykN1O

looks like its a WatchMe log not Memorize

Thanks!

I tried 22-Jun-2009 iso
http://download.sugarlabs.org/soas/releases/soas-strawberry.iso
it sounds bad(pulseaudio is too old) but Memorise-34 doesn't crash(in qemu and native), maybe its a VirtualBox issue.

Could you try native boot.. and better w/ one of last soas dev releases.

comment:18 follow-up: Changed 11 years ago by CarolineM

Hi Alsroot,

My focus right now is on the GPA pilot and we are on Strawberry until Blueberry is released. I don't think it makes sense to try to interim updates of the underlying OS. It maybe that the right answer is to wait for BlueBerry before we add the speak guy?

comment:19 in reply to: ↑ 18 Changed 11 years ago by alsroot

Replying to CarolineM:

Hi Alsroot,

My focus right now is on the GPA pilot and we are on Strawberry until Blueberry is released. I don't think it makes sense to try to interim updates of the underlying OS. It maybe that the right answer is to wait for BlueBerry before we add the speak guy?

yeah, BlueBerry would be the best option anyway.
I'll install VirtualBox to try to reproduce crash w/ Strawberry.

comment:20 Changed 9 years ago by godiard

  • Resolution set to obsolete
  • Status changed from assigned to closed

Is working ok in actual releases.

Note: See TracTickets for help on using tickets.