Opened 13 years ago

Closed 13 years ago

#942 closed defect (fixed)

Paint Activity: text entries are not working

Reported by: morfila Owned by: alsroot
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Paint Version: 0.83.x
Severity: Critical Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: New

Description

Activity Paint (version 26) has some problem with the text entries in the toolboxes (e.g. "Activity" Toolbox): the text can not be edited. If I start clicking very fast over the text entry and type text, some of the characters are written in the entry, but most of them are discarded.

This doesn't happen with other activities, like Browse.

I've tried adding a new toolbox to the activity and my entry widget is experiencing the same behavior.

I've tested this with Sugar in an XO and sugar-jhbuild.

Regards,

Marcos

Change History (3)

comment:1 Changed 13 years ago by garycmartin

  • Bug Status changed from Unconfirmed to New
  • Component changed from sugar to Paint
  • Distribution/OS changed from Fedora to Unspecified
  • Owner changed from tomeu to alsroot

Yep, this has been a bug for a long time. FWIW, switching to the text->type input tool (as if you want to add text to a painting) the bug goes away, so I assume something is hogging keyboard focus/events for other tools.

comment:2 Changed 13 years ago by morfila

I tried to find a workaround, but had no success.

I tried to reproduce the selection of toolbars Text/Type and then Tools/Pencil by overriding method "set_active" of class OficinaActivity. I was hopping that it would have the same effect as clicking in the Text/type toolbar button and then in the Tools/Pencil button. Not good enough as it doesn't work :-)
Here's the text I added to class OficinaActivity:

def set_active(self, active):

activity.Activity.set_active(self, active)
from toolbox import TextToolbar, ToolsToolbar
self.area.set_tool(TextToolbar._ACTION_TEXT)
self.area.set_tool(ToolsToolbar._TOOL_PENCIL)

Does anyone have any idea of when would this bug be addressed?

Regards,
Marcos

comment:3 Changed 13 years ago by alsroot

  • Resolution set to fixed
  • Status changed from new to closed

at the end I've just commented grab_focus out
looks like it works(for text and non-text tools) fine w/o it

http://git.sugarlabs.org/projects/paint/repos/mainline/commits/4447aa0bfc0b00251aeda6cd2716c48d2f90bc16

Note: See TracTickets for help on using tickets.