Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#701 closed defect (fixed)

Let user upgrade system activity from .xo

Reported by: alsroot Owned by: alsroot
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: 0.85.x
Severity: Critical Keywords: r+
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

at present sugar raise exception but install .xo
thus there are two activities in activities list

Attachments (5)

sugar-703.patch (2.1 KB) - added by alsroot 10 years ago.
sugar-701.2.patch (2.1 KB) - added by alsroot 10 years ago.
sugar-701.3.patch (2.1 KB) - added by alsroot 10 years ago.
sugar-701-toolkit.patch (757 bytes) - added by alsroot 10 years ago.
Final patch for 0.86 (for sugar-toolkit)
sugar-701.patch (3.3 KB) - added by alsroot 10 years ago.
Final patch for 0.86

Download all attachments as: .zip

Change History (16)

comment:1 Changed 10 years ago by alsroot

  • Severity changed from Unspecified to Blocker

Changed 10 years ago by alsroot

comment:2 Changed 10 years ago by alsroot

attachment sugar-703.patch added

oops.. missed

Changed 10 years ago by alsroot

Changed 10 years ago by alsroot

comment:3 Changed 10 years ago by alsroot

sugar-701.3.patch prevents loading two activities at the same time(one system with old version and one newest from ~/Activities)
anyway this patch should be treated as workaround code for 0.84

comment:4 Changed 10 years ago by tomeu

  • Cc r- added; r? removed
  • Milestone changed from 0.84 to 0.86
  • Severity changed from Blocker to Critical

This problem may be better solved for 0.86. For 0.84, I have created a separate ticket for the most pressing issue: #707.

comment:5 Changed 10 years ago by alsroot

  • Resolution set to wontfix
  • Status changed from new to closed

Looks like there is no clear position for that case in 0.86 cycle, for leter release fix issue could be fixed while rethinking the whole idea of preinstalled activities

comment:6 Changed 10 years ago by alsroot

  • Resolution wontfix deleted
  • Status changed from closed to reopened
  • Version changed from 0.84.x to 0.85.x

look like we need overriding fix at least
"higher versions in ~/Activities overriding the ones in /usr is also good"

Changed 10 years ago by alsroot

Final patch for 0.86 (for sugar-toolkit)

comment:7 Changed 10 years ago by alsroot

  • Cc r- removed
  • Keywords r? added

two last patches let users upgrade activities that were installed to non ~/Activities directory

comment:8 Changed 10 years ago by tomeu

  • Keywords r+ added; r? removed
  • Owner changed from tomeu to alsroot
  • Status changed from reopened to assigned

r+ with the changes discussed in #sugar, please push.

Changed 10 years ago by alsroot

Final patch for 0.86

comment:9 Changed 10 years ago by alsroot

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:11 Changed 6 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.