Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#677 closed defect (fixed)

Soas2-appliance not booting in VirtualBox with kernel 2.6.29-0.258.2.3.rc8.git2.fc11.i586

Reported by: lucian Owned by: sdz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar on a Stick (SoaS) Version: Unspecified
Severity: Major Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Resolved

Description

After the grub bootup choice, it just freezes.

I first tried http://download.sugarlabs.org/soas/appliances/soas2-20090401.tar.gz.

Then I tried older snapshots. Soas2-appliance vdmks boot up, but only with 2.6.29-0.258.2.3.rc7*. They don't boot with *rc8* either.

Change History (4)

comment:1 Changed 12 years ago by lucian

I tried the latest soas appliance (soas2-20090403) and I get the same problem.

I also tried disabling all VirtualBox speed-up options (3D, VT-x, IO APIC, etc.), same problem.

comment:2 Changed 12 years ago by wadeb

I encountered the same problem.

It seems that the reason is that /boot/grub/grub.conf sets initrd to /boot/initrd-uname -r.img, but there is no initrd image file in /boot/!

I was able to get it to boot by deleting the initrd line using the Grub interactive editing menu.

Anyway, after all that I was still unable to get it to boot properly. It gets through firstboot alright, but subsequently fails to start Sugar. You can get to a console (Ctrl-Alt-F2) but I haven't figure out where to go from there to fix it.

comment:3 Changed 12 years ago by sdz

  • Bug Status changed from New to Resolved
  • Resolution set to fixed
  • Status changed from new to closed

The Soas2-appliance images have undergone major changes. From what I hear on the MLs, the latest snapshots have been confirmed to be booting successfully in VirtualBox and VMware.

comment:4 Changed 11 years ago by sascha_silbe

  • Distribution/OS changed from SoaS to Unspecified

Bulk change distribution=SoaS -> component=SoaS

Note: See TracTickets for help on using tickets.