Opened 15 years ago

Closed 14 years ago

Last modified 11 years ago

#632 closed defect (fixed)

Linux-specific terminology in Removable Storage context menu.

Reported by: wadeb Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Minor Keywords: sugar-love
Cc: eben Distribution/OS: Unspecified
Bug Status: Unconfirmed


When there is a removable storage device mounted, it gets an icon in the Frame.

The context menu for this has an 'Unmount' option. This is a Linux specific term and doesn't make sense to a non technical user.

I think 'Remove' would be a better name for this option, since clicking it will 'Remove' the device from the frame, and will allow the user to safely 'Remove' the device from the computer.

Does anyone know why 'Unmount' was chosen in the first place?

Change History (5)

comment:1 Changed 15 years ago by eben

It likely just slipped through. The design is posted here:
Your suggestion to name it "Remove" sounds just as good, or perhaps better, than "Disconnect". Both are far better than "Unmount".

comment:2 Changed 15 years ago by tomeu

  • Milestone changed from Unspecified by Release Team to 0.86

comment:3 Changed 15 years ago by homunq

  • Keywords sugar-love added

comment:4 Changed 14 years ago by tomeu

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 11 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.