Opened 12 years ago

Closed 12 years ago

#60 closed defect (fixed)

tubes do not work when sharing over gabble in F10

Reported by: erikos Owned by: erikos
Priority: major Milestone:
Component: Sugar Version:
Severity: Blocker Keywords:
Cc: guillaume.desmottes@…, morgan.collett@… Distribution/OS: Unspecified
Bug Status: Resolved

Description

Tested in F10(0.82) and Joyride-2566(0.83.x)

  • sharing using chat does work
  • sharing using browse and write does not
  • sharing works if I use sugar head (0.84) and 0.82 (two sugar-jhbuild instances)

Attachments (4)

presenceservice.log (65.7 KB) - added by erikos 12 years ago.
org.laptop.AbiWordActivity-1.log (14.5 KB) - added by erikos 12 years ago.
org.laptop.WebActivity-1.log (16.6 KB) - added by erikos 12 years ago.
fix-muc-dtube.patch (542 bytes) - added by gdesmott 12 years ago.
Patch fixing the bug in telepathy-gabble 0.7.18

Download all attachments as: .zip

Change History (19)

Changed 12 years ago by erikos

Changed 12 years ago by erikos

Changed 12 years ago by erikos

comment:1 Changed 12 years ago by erikos

was too big to attach here: dev.laptop.org/~erikos/telepathy-gabble.log

comment:2 Changed 12 years ago by morgs

  • Cc morgan.collett@… added

telepathy-gabble and telepathy-salut were built in joyride without the patches we need for rainbow. I've requested OLPC-4 branches and am rebuilding telepathy-* for joyride now.

comment:3 Changed 12 years ago by morgs

Guillaume says there is a regression in tubes in gabble 0.7.12.

I'll update joyride to the latest gabble/glib versions.

Someone needs to file a bugzilla ticket for Fedora because F-10 ships the broken 0.7.12. bpepple is the maintainer there.

comment:6 Changed 12 years ago by alsroot

  • Bug Status set to Unconfimed
  • Distribution/OS set to Unspecified
  • Severity set to Blocker

have a similar problems
full logs (from both hosts and test activity) are here:
http://people.sugarlabs.org/~alsroot/bugs/#60/

telepathy-glib-0.7.{20,24}
telepathy-gabble-0.7.18

activities could not remote_call/send_signals (see dbus errors in logs) to dbus tubes

rollback telepathy-gabble to 0.7.17 helps in all cases (various telepathy-glib-versions/distributions)

comment:7 Changed 12 years ago by gdesmott

You're right muc D-Bus tubes have been broken in gabble 0.7.18. Sorry for that, my bad. The following patch apply on 0.7.18 and fix the problem.
I'll make a new release soon.

Changed 12 years ago by gdesmott

Patch fixing the bug in telepathy-gabble 0.7.18

comment:8 follow-up: Changed 12 years ago by gdesmott

telepathy-gabble 0.7.19 has been released and fixes this bug.

comment:9 in reply to: ↑ 8 Changed 12 years ago by alsroot

Replying to gdesmott:

telepathy-gabble 0.7.19 has been released and fixes this bug.

yup, it works for me, thanks

comment:10 Changed 12 years ago by gdesmott

Cool. I guess we can close this bug as soon the fix reachs F10 then.

comment:12 Changed 12 years ago by morgs

I've put gabble 0.7.19 into jhbuild.

comment:13 follow-up: Changed 12 years ago by erikos

  • Bug Status changed from Unconfimed to Needinfo

Can someone please verify that this is gone? In F11 or Soas.

comment:14 in reply to: ↑ 13 Changed 12 years ago by alsroot

Replying to erikos:

Can someone please verify that this is gone? In F11 or Soas.

SoaS-1 uses backported from f11 versions and they are ok

comment:15 Changed 12 years ago by erikos

  • Bug Status changed from Needinfo to Resolved
  • Resolution set to fixed
  • Status changed from new to closed

As, it is working fine now, we can close this one.

Note: See TracTickets for help on using tickets.