Opened 12 years ago

Closed 10 years ago

#596 closed defect (wontfix)

SoaS has no network access

Reported by: jdsimmons Owned by: sdz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar on a Stick (SoaS) Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

When I boot up SoaS using a boot CD plus the USB stick Sugar starts up OK but I can't access the network at all. Running /sbin/ifconfig from the Terminal activity gives me the loopback device but nothing else. I am using Soas1-200903191225.iso. I need the boot CD because my computer does not support booting from USB.

I have check dmesg and see no evidence that it is even trying to set up a network connection.

Change History (7)

comment:1 Changed 12 years ago by ashar

I ran Soas1-200903191225.iso and the machine did not add a nameserver entry to /etc/resolv.conf

Second time I booted up the DNS entry was there.

comment:2 Changed 12 years ago by jdsimmons

Another problem with booting up by CD is I get no sound. I tried Tam Tam and was not able to make any sounds at all.

In addition to the boot.iso I also tried the recommended Fedora 10 install CD, but was unable to figure out how to boot off a USB thumb drive with it.

None of the computers in my home or my office can be booted off a thumb drive. One of my computers has BIOS settings for booting off a USB mounted floppy drive, CDROM drive, or hard drive. I tried all three possibilities but none of them worked. Thus I don't know if the boot CD is the problem as it is the only way I can boot SoaS.

comment:3 Changed 12 years ago by jdsimmons

I tried booting the same USB stick using a Plop Boot Manager diskette, and using that I was able to get network access just fine. Still no sound, though. This tells me that we need an updated boot CD.

comment:4 Changed 12 years ago by erikos

Hi jdsimmons,

what boot helper CD are you using? We are currently looking for a working one :/

Thanks,

Simon

comment:5 Changed 12 years ago by jdsimmons

Simon,

The only thing that worked well for me was the Plop Boot Manager diskette, a freeware product (not open source) you can get here:

http://www.plop.at/en/bootmanager.html

You install it on a diskette. You boot up with the diskette and it gives you a menu of devices and partitions you might be able to boot from. One of the entries is "USB". It worked for me when my USB stick was inserted into a USB 1.1 port connected to the computer motherboard. It did not work with a USB 2.0 port on a PCI card. On an HP Vectra I had to use text mode (press Ctrl-Esc while its starting up) to get a menu, but it worked fine on an IBM NetVista using its default graphics mode. Booting up was slow but everything but sound worked fine once it was booted.

I used the recommended CD when I got the no network access I reported, and could not figure out how to use the Fedora install CD to boot up from the USB drive, as reported above.

comment:6 Changed 11 years ago by sascha_silbe

  • Distribution/OS changed from SoaS to Unspecified

Bulk change distribution=SoaS -> component=SoaS

comment:7 Changed 10 years ago by pbrobinson

  • Resolution set to wontfix
  • Status changed from new to closed

This release of Sugar on a Stick is end of life. Please test against the latest version of SoaS available at http://spins.fedoraproject.org/soas/

If the problem still exists please open a new bug report detailing the issues in the new release or post to the mailing list.

Please join the mailing list at http://lists.sugarlabs.org/listinfo/soas for assistance or questions about Sugar on a Stick.

Note: See TracTickets for help on using tickets.