Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#553 closed defect (fixed)

jhbuild fails to build on clean fedora 10 install (libsoup-2.4)

Reported by: garycmartin Owned by: sascha_silbe
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: sugar-jhbuild Version: Git as of bugdate
Severity: Major Keywords:
Cc: wadeb Distribution/OS: Fedora
Bug Status: Needinfo

Description

A bunch of things didn't go smoothly and needed some hacking and poking, but the one that caused most burnt time was in the ./sugar-jhbuild build step where it complains about missing libsoup-2.4 for telepathy-salut.

I found a bunch of past email and a closed ticket about it, but no one said where/how they actually got 2.4 (the yum reps don't have it), some suggested 2.4 came with some other random install they had made (Epiphany?). I tried both manually building from 2.4 from source, which seemed to have no effect; I then tried yum install libsoup-devel, which also seemed to have no effect. I tried skipping the module for now, but I got a heap of fails a little further on and decided to ctrl-c the whole build attempt.

After a reboot (due to some resolution issues I needed to fix in the VirtualBox VM), I just tried the build again and this time it succeeded – not which step had actually resolved the libsoup issue.

Change History (7)

comment:1 Changed 12 years ago by sascha_silbe

  • Severity changed from Minor to Major
  • Status changed from new to accepted
  • Version changed from Unspecified to Git as of bugdate

sugar-jhbuild should now build libsoup from source on Fedora. Please uninstall the binary packages and try again.
Warning: This is my first try at adding modules to sugar-jhbuild, so it may cause any kind of damage. :)

comment:2 Changed 12 years ago by garycmartin

  • Bug Status changed from Unconfimed to Resolved
  • Resolution set to fixed
  • Status changed from accepted to closed

Having only just got jhbuild running I was a little worried about breaking things :-) but I uninstalled the libsoup binary package I'd manually added; then did a jhbuild update, build, and run. I saw jhbuild download libsoup, and everything re-built and seems to be running just fine. Thanks Sascha!

comment:3 Changed 12 years ago by sascha_silbe

Thanks for testing!

comment:4 Changed 12 years ago by wadeb

  • Resolution fixed deleted
  • Status changed from closed to reopened

With the latest jhbuild, I'm seeing this now.

Steps:

  • Installed a clean Fedora 10 from the LiveCD into a new VirtualBox VM.
  • Ran yum update to update the system.
  • Cloned sugar-jhbuild.
  • Ran yum install ./sugar-jhbuild depscheck
  • Ran ./sugar-jhbuild build.
  • Errored about libsoup-2.4.
  • Dropped to shell.
  • Ran yum install libsoup-devel
  • Exited shell, install continued fine (failed later with gabble issue).

comment:5 Changed 12 years ago by sascha_silbe

  • Status changed from reopened to accepted

I just found an undeclared dependency of telepathy-gabble on libsoup-2.4 and fixed it. This could be part of your problem.
libsoup-devel is 2.2 and thus too old, you can safely uninstall it.
Please update and try again.

comment:6 Changed 12 years ago by sascha_silbe

  • Bug Status changed from Resolved to Needinfo
  • Cc wadeb added

wadeb, does it work for you now?

comment:7 Changed 12 years ago by garycmartin

  • Resolution set to fixed
  • Status changed from accepted to closed

Closing this as it seems fixed here, wadwb please do reopen if it is still an issue for you!

Note: See TracTickets for help on using tickets.