Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#4894 closed defect (fixed)

Frame settings don't apply if you move too fast

Reported by: SAMdroid Owned by:
Priority: High Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Major Keywords: patch
Cc: Distribution/OS: Fedora
Bug Status: Unconfirmed

Description (last modified by SAMdroid)

Was Frame settings doesn't allow option other that edge delay = 0

How to reproduce:

  1. Open my settings then frame
  2. Change edge delay to 0.9 from never
  3. Click the tick to save the settings

Result:

  • No prompt for restart
  • Re-viewing the settings shows it is on instant

Expected result:

  • Prompt me for a restart
  • Set the setting to what I set it to!

Notes:

Tested on fedora 24 rawhide with sugar 0.106.0 in sugar-runner

Reproduces most of the time

Change History (5)

comment:1 Changed 7 years ago by tch

Still present in 0.107.0, BUT, the problem is the timeout, if you make the change and then quickly press the save button it won't work, but if you wait 1-1.5 seconds it will prompt for restart and it will store the changes.

comment:2 Changed 7 years ago by quozl

An _APPLY_TIMEOUT is inherited from SectionView, this is the one second delay. The frame control panel view failed to check for slider change at the time the apply button is pressed.

comment:3 Changed 7 years ago by SAMdroid

  • Description modified (diff)
  • Keywords patch added
  • Summary changed from Frame settings doesn't allow option other that edge delay = 0 to Frame settings don't apply if you move too fast

comment:4 Changed 7 years ago by SAMdroid

  • Resolution set to fixed
  • Status changed from new to closed

I merged the patch.

comment:5 Changed 7 years ago by quozl

Is in 0.107.1

Note: See TracTickets for help on using tickets.