Opened 7 years ago

Closed 7 years ago

#4740 closed defect (fixed)

sugar activities updater: signals are not disconnected

Reported by: godiard Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

When the view is started, siganals are connected to the updater, but now the updater is a singleton, and are not disconnected when the view is closed.
This produce problems like:

  • If you go to the updater, and close it a few times, and after that, enter again and try to do a update, with debug enabled, will see the finalize signal is received multiple times.

1394719071.493141 DEBUG root: ActivityUpdater.finished_cb

  • If you select only one activity to update, in the log will see other activities updated! That is because by default all the activities are updated, and the old views are still receiving the updater events.

Change History (1)

comment:1 Changed 7 years ago by Gonzalo Odiard

  • Resolution set to fixed
  • Status changed from new to closed

Updater: disconnect signals when cp view is closed - Fixes #4740

When the updater cp view is created, connect to updater signals.
The updater is a singleton, and the signals are not disconnected,
then produce the errors detailed in the ticket.

Signed-off-by: Gonzalo Odiard <godiard@…>

Changeset: 1d99e63dea55cd27736811c1d071101d89baf00c

Note: See TracTickets for help on using tickets.