Opened 8 years ago

Closed 7 years ago

#4608 closed defect (fixed)

View Source: can not duplicate activity bundle if a gtk3 or sugar web activity

Reported by: erikos Owned by:
Priority: Unspecified by Maintainer Milestone: 0.100.0
Component: Sugar Version: Git as of bugdate
Severity: Major Keywords:
Cc: Distribution/OS: Fedora
Bug Status: New

Description

Steps to reproduce: use the palette of the activity bundle source to duplicate that activity, you will get an error that "dist_name" is not a valid keyword argument. See the bundlebuilder Config.

It was a valid keyword in the gtk2 toolkit, see the old bundlebuilder.

Change History (3)

comment:1 Changed 8 years ago by erikos

This is part of a broader set of "View source" issues: https://github.com/sugarlabs/sugar/pull/85#issuecomment-23206926

comment:2 Changed 8 years ago by manuq

  • Bug Status changed from Unconfirmed to New

Great, confirmed. This is a new blocker for 0.100 .

comment:3 Changed 7 years ago by Gonzalo Odiard

  • Resolution set to fixed
  • Status changed from new to closed

Fix cloning activity in sugar - SL #4608

Probably this code was not included in the initial port from gtk2 to
gtk3, because is only used by Sugar, but now we need it.

I changed the way the parameter dist_name is used,
then a complementary patch in sugar is needed

Fixes #4608

Signed-off-by: Gonzalo Odiard <gonzalo@…>

Changeset: b8074549f6d1ed984771a988352a1c30c377bfc4

Note: See TracTickets for help on using tickets.