Opened 8 years ago

Closed 8 years ago

#4402 closed defect (fixed)

pointless ellipsizing of text blocks

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

eg paste the blocks of walters prime number sample from a web browser to a blank ta canvas

I am getting longer text blocks pointlessly ellipsised, pointless because the ellipses are nearly exactly the width of the missing text.

eg action ...rement color

comment ...lculate prime factors

action ...t next prime factor

clicking it to open then clicking canvas to close shows all the text block

action increment color
comment calculate prime factors
action get next prime factor

Change History (2)

comment:1 Changed 8 years ago by tonyforster

the blocks display ok at unshrunk display, the problem is at the first level of shrink

comment:2 Changed 8 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

I refactored the ellipsis code and don't think this is still an issue. Please reopen if the bug is still present.

Note: See TracTickets for help on using tickets.