Opened 8 years ago

Closed 7 years ago

#3618 closed enhancement (fixed)

Watch cursor should be shown when invert colors function is called

Reported by: humitos Owned by: godiard
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Paint Version: Unspecified
Severity: Unspecified Keywords:
Cc: humitos Distribution/OS: Unspecified
Bug Status: Resolved

Description

Steps to reproduce it:

  1. Open Paint
  2. Draw some lines
  3. Select an area
  4. Click on "Invert Colors"

Issue:

While the operation is being performed "normal" cursor is shown.

Expected behavior:

We should show the watch cursor to indicate that the operation is being performed.

Environment:

XO 1.75 os11

Change History (5)

comment:1 Changed 8 years ago by humitos

  • Owner changed from godiard to humitos
  • Status changed from new to accepted

comment:2 Changed 8 years ago by humitos

Maybe this ticket is related with #3559, but I'm not sure because the WATCH cursor is working for the Bucket tool, for example.

The Paint code is doing the things right: when invert_colors function is called this function is executed through gobject.idle_add and in the middle self.window.set_cursor(gtk.gdk.Cursor(gtk.gdk.WATCH)) is called. That method sets the WATCH cursor while the function is being performed.

I can confirm that this is working on Fedora 16 and Debian Testing (sugar-jhbuild) with the git version of Paint.

This doesn't work on:

  • XO 1.75 os12 and os11
  • XO 1.5 os9

comment:3 Changed 8 years ago by humitos

  • Owner changed from humitos to godiard
  • Status changed from accepted to assigned

I'm reassinging this ticket to Gonzalo because is doing a great work on paint

comment:4 Changed 7 years ago by ignacio

  • Bug Status changed from Unconfirmed to Resolved

comment:5 Changed 7 years ago by godiard

  • Resolution set to fixed
  • Status changed from assigned to closed

Thanks Ignacio. Commited a similar patch, solving #4674 too.

Fixed by f6754ca59c4b6fbcf6f7b253ac845901452421f6

Note: See TracTickets for help on using tickets.