Opened 9 years ago

Last modified 9 years ago

#3546 new defect

Sugar instalation by livecd-iso-to-disk fail

Reported by: aurium Owned by: pbrobinson
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar on a Stick (SoaS) Version: Unspecified
Severity: Blocker Keywords: ClasmatePC, install
Cc: aurium@… Distribution/OS: Fedora
Bug Status: Unconfirmed

Description (last modified by aurium)

Hi folks,

My group are considering to replace it's original ClasmatePC SO MetaSYS (used on Brasil) with Sugar.

I had tested Sugar Live from http://wiki.sugarlabs.org/go/Downloads#GNU.2FLinux added to my pendrive with UNetBootin and works well.

(Update: I also tried to create the live pendrive using the tools_livecd-iso-to-disk.sh and that works as live pendrive, but the installation fails again by the same way)

The problem is when we try to install it.

I umount /dev/sdb1 (where is the HD) and run:

/mnt/live/LiveOS/livecd-iso-to-disk --reset-mbr --overlay-size-mb 300 --home-size-mb 175 --delete-home --unencrypted-home /dev/sda1 /dev/sdb1

That work with no error. Nice...
But when i reboot the laptop i see this error:

dracut Warning: No root device "live:/dev/disk/...

I see no /dev/disk and no /dev/sd* ... Where is the problem?

Change History (4)

comment:1 Changed 9 years ago by sascha_silbe

  • Component changed from untriaged to Sugar on a Stick (SoaS)
  • Owner set to pbrobinson

comment:2 Changed 9 years ago by pbrobinson

What version of SoaS are you using? What OS are you using to run livecd-iso-to-disk

comment:3 Changed 9 years ago by aurium

  • Description modified (diff)

What version of SoaS are you using?

What comes here: Fedora-16-i686-Live-SoaS.iso

  • Sugar on a Stick 6 (Pineapple)

What OS are you using to run livecd-iso-to-disk?

The Sugar on a Stick (Fedora live) itself!

Steps on the fist try:

  1. putted Fedora-16-i686-Live-SoaS.iso on my pendrive
  2. plugged the pendrive on the ClassmatePC
  3. turned on the ClassmatePC
  4. selected the pendrive to boot
  5. wait for the sugar interface
  6. open the sugar terminal
  7. switch to root
  8. runed /mnt/live/LiveOS/livecd-iso-to-disk --reset-mbr --overlay-size-mb 300 --home-size-mb 175 --delete-home --unencrypted-home /dev/sda1 /dev/sdb1
  9. rebooted and removed the pendrive before the restart.
  10. Then, the error happens.

Also tried to copy the Fedora-16-i686-Live-SoaS.iso in the pendrive and run:

  1. ...
  2. runed /mnt/live/LiveOS/livecd-iso-to-disk --reset-mbr --overlay-size-mb 300 --home-size-mb 175 --delete-home --unencrypted-home /mnt/live/Fedora-16-i686-Live-SoaS.iso /dev/sdb1
  3. rebooted and removed the pendrive before the restart.
  4. Then, the error happens.

comment:4 Changed 9 years ago by pbrobinson

If you actually want to install SoaS onto the internal drive of the Classmate you should run the "liveinst" command. That will do a proper install of the live image onto the internal Drive. I suggest you look at using SoaSv7 that will be released on May 22nd. You can get a test image from the link below. It has a lot of improvements over the Fedora 16 based SoaSv6 like a webkit based Browse, a working Read amongst other great improvements.

http://alt.fedoraproject.org/pub/alt/stage/17.TC3/Spins/i686/Fedora-17.TC3-i686-Live-SoaS.iso

Note: See TracTickets for help on using tickets.